Preventing Pausing



  • Hi,
    this may be an odd feature for 3D Printers, but for machines that also use a laser it may be useful, unless there is annother way of doing it already, that i have yet to figure out.

    When Laser Cutting and hitting pause, there is a chance the machine stops during a travel move (in my case travels are a few moves, because its referencing the height each time on the material with the z axis prior to a cut which increases the chance of pausing during a travel), which is fine of course, but the problem is that either i setup pause.g and resume.g to turn off/on the laser and compressor as it should when pausing during a cut, but then it will start the laser early if resuming during a travel move.

    A simple way to fix that may be to have a g-code that we can issue for times during which the machine may not be paused, so for instance that could be issued prior to a travel move, and then cancelled when starting the cut.

    Not sure if this is useful for many people and its certainly not urgent, because after a pausing i can manually alter the resume.g file depending on the machine state, but that can be tedious when debugging the machine in general trying simple square cuts which basically give you a 50:50 chance of pausing during either type of motion.

    Anyways, thank you very much for the awesome reprap firmware!



  • Have you set your Duet to Laser Mode with M452?
    As far as I understand, this would mean that the laser will only be on while moving and will automatically turn off when not moving.

    I'm still waiting for my laser to arrive, so I have not tested this yet. But maybe that's all you need 🙂

    If you're using the laser in a 3D printer (as I think you do), you can change modes on the fly in the tpreN.g files.
    So M451 to enable FFF mode in every TpreN.g that's an extruder, and M452 P3 R255 F200 in the tpreN.g for the laser.

    If you're going to use M452, make sure to keep mind of this:

    Very important! If you use M452 to put your machine into Laser mode and are running Firmware 2.02 or above, you must replace all S parameters in G0/G1 commands in homing files etc. by H parameters. This is because S is now used to control laser power.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.