Maestro on Ender 3



  • I’m trying to set this maestro up on my ender. So far nothing has gone right. I went through the firmware configuration, to the best of my ability. Most answers I wasn’t too sure on. Then I finally got to the web interface. Tried homing my axis, and the X and Y will move about 10mm then stop. I press home again. Same thing. So I press home Z, and it starts to move the gantry down and once it hits my end stop, it keeps trying and clicking, and won’t stop until I hit the emergency stop.

    So, for one, I strongly need assistance getting this set up properly!

    And my second issue is, whenever I press the emergency stop button, I have the hardest time getting this machine to reconnect to the web interface! I first try to wait.... nothing... I have tried the reset button, and nope. Sometimes, removing power and resetting that way has worked. But this most recent time, I’ve had to just remove the SD card and load in fresh config files before I could actually regain connection! Whyyyyyy! Lol.

    I’ve spent hours all weekend searching through the forums and on google. The Maestro is seriously lacking support. It’s all WiFi this and WiFi that! Ugh.

    Feeling helpless.



  • Well now I can’t maintain web control connection at all. If I have the printer powered off, and the USB is connected, then I can access web control! But of course, the status is “off” so there ain’t much I can do. Once I switch on the main power, I completely lose connection!! Even my router says that my ender is “disconnected”

    What gives?


  • administrators

    I've just replied to another post which I presume is also yours. My guess is that you have debugging enabled so you need to turn it off using M111 S0, or avoid enabling it in the first place.



  • @dc42 it was. After no reply here, I had assumed that maybe I had posted the question in the wrong category. I’ve replied there.



  • this happen to me i fix by going to endstop config and switch from false to true and that fix the homing problem