DWC access not working? D2 Maestro



  • Brand new set up; maestro on my ender 3.
    For a few hours, I had access to the web conroller just fine. Then as I was trying to configure some motor directions, I had to press the emergency stop. I have since been unable to connect! I’ve tried reinstalling the firmware. Re configured everything fresh. Still nothing.
    If I’m connected via USB and I’m in YAT, the m552 shows that the network is enabled and it gives me an IP. Under these same conditions, I can access the DWC. But when I disconnect from USB and turn on the printer, DWC disconnects and will not ever reconnect. I can see in my router that the printer IS connected, and it has an IP address there, but it just will not open in my browser!

    Please help! I am at such a loss here.


  • administrators

    Check that you do not have debugging enabled, by sending M111 without parameters. It should report that debugging is off.

    Warning: if you use Repetier Host to communicate with the Duet, it will enable debugging unless you turn off command echoing and some other features. This is because Repetier did their own version of M111, apparently ignoring the existing meaning documented in the wiki at reprap.org. In firmware 2.03beta2 I've made a change that I hope will make this less of a problem, by requiring a P parameter as well to enable debugging.



  • @dc42 I’m afraid it may be a little late for that.

    I was following through this guide:
    https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond
    I got through the steps to erase the board, And now I can’t get the board to connect to any com on my computer. I’ve tried multiple USB ports and multiple USB cords. The cord that came with the board was working perfect until now. I don’t believe that’s to blame.

    When I plug in with the USB, the usual LEDs come on like normal.


  • administrators

    • Which operating system are you using in your PC?

    • Have you tried rebooting the PC? Windows in particular has a habit of turning off USB ports if the device attached to them changes too fast for its liking.

    • After you installed the Erase jumper and powered the Duet up, did you remove it again?



  • @dc42 I am using windows 7. I did try rebooting it. I have a MacBook in the house that I haven’t tried yet.

    I first tried: Plug into usb. Install jumper on erase pins for a few seconds. Remove jumper. Press reset. Remove USB. wait. Plug in usb...... Nothing.

    Then tried: install jumper. Plug into usb. Remove jumper. Press reset. Remove usb. Wait. Plug usb in......... Nothing

    Then I tried to hold the reset as I plugged in the usb..... still nothing.


  • administrators

    Using your Windows machine (because that is what I am most familiar with):

    • In Device Manager, have you expanded Ports - Com & LPT?
    • Have you checked whether there an Unknown Device?
    • Does anything unusual show up if you expand the USB section?


  • @dc42 the ports-com isn’t there right now. I could be wrong, but I think I’ve noticed it only shows up when I have something (USB) connected, right? Cause I’ve had the device manager open before (a few days ago) ready to look for that section, and it didn’t pop up until I plugged the board in. It’s not doing that now.

    I’m not too familiar with windows. I use the Mac for 95% of my computer needs




  • administrators

    It's a shame you erased the firmware, because that should only be done if the board is completely unresponsive. But I guess you should ask for a replacement under warranty now.



  • That stinks. I’ve contacted M3D. I appreciate your help!


Log in to reply