Duet expansion breakout board not helping me



  • Hello.
    I am using Stepper Motor Closed Loop Driver for my XYZ axis. which require input voltage of 5 volts, but Duet 2 Ethernet only provide 3.3v output at motor. that is why i order Duet expansion breakout board.
    I did all changes in config.g which are mentioned Duet3D Documentation. but now only one axis is moving.
    0_1552655787757_TB2egzAlFXXXXXaXpXXXXXXXXXX_!!47255110.jpg
    Second step :
    l take Nema 17 and DM542 Stepper Motor Driver, i did all required changes in Config.g then all axis started moving.
    0_1552655813177_0b3bf454-3659-49bc-9778-1aa5f4337339.jpg
    Why is it so..
    Troubleshooting points
    1.Checked Motor connections.
    2.Checked wires crimping & connectivity.
    3.Tried with different ports board on expansion
    breakout board
    Please help me..


  • administrators

    1. Did you use the M584 command to map the required axes to the external drivers?
    2. Did you use the T parameter on the M569 commands for the external drivers to extend the step pulse timing? Almost all external drivers need this.
    3. Most external drivers are happy with the differential signals provided by the breakout board. However if your drivers really do need 5V then you can achieve this by connecting PUL+, DIR+ and ENA+ from the external driver to +5V on one of the heater/servo connectors on the breakout board, instead of to the + pins on the 6-pin output connector.


  • Hello,
    *The first two point were covered and by doing so only one of the motor responds to the homing command(i.e z axis motor), the Y-axis motor is enabled and the X-axis motor remains disabled.
    *Only one motor respond at a time when the three are connected (have checked it connecting individually).
    *I have attached the config.g file below for refrence.
    *When connecting PUL+, DIR+ and ENA+ from the external driver to +5V on one of the heater/servo connectors on the breakout board, instead of to the + pins on the 6-pin output connector all the motors are in enabled state and follows no commands.
    *In the following config.g the motors were conneted to:
    X-motor- E6 ,DRIVE-9 (on expansion board)
    Y-motor-E5 ,DRIVE-8 (on expansion board)
    Z-motor-E4 ,DRIVE-7 (on expansion board)
    CONFIG.G
    ; ----------------------Drives definition----------------------------------------------
    ; ----Drives driver direction, enable polarity and step pulse timing----------------------------------------------
    ;------------------X MOTOR-------------------------------------------------------------
    ;M569 P0 S0 ; Drive 0 goes forwards S0 /x motor on duet board
    M569 P9 R1 S1 T10:10:15:0 ; Drive 5 goes forwards S0/ x motor on expansion E2
    ;------------------Y MOTOR-------------------------------------------------------------
    ;M569 P1 S1 ; Drive 1 goes forwards S0/Y motor on duet board
    M569 P8 R1 S1 T10:10:15:0 ; Drive 6 goes forwards S0/Y motor on expansion E3
    ;-----------------Z MOTOR--------------------------------------------------------------
    ;M569 P2 S1 ; Drive 2 goes forwards S0 /Y motor on duet board
    M569 P7 R1 S1 T10:10:15:0 ; Drive 7 goes forwards S0 /Z motor on expansion E4
    ;-----------------EXTRUDER MOTOR---------------------------------------------------------
    M569 P3 S0 ; Drive 3 goes forwards S0 /extruder motor on duet board E0
    ;M569 P8 R1 S0 T10:10:15:0 ; Drive 8 goes forwards S0/ extruder 1 on expansion E5
    ; ----- END Drives driver direction, enable polarity and step pulse timing END----------------------------------------------
    ;-----------------------DRIVE MAPPING------------------------------------------------------------

    M584 X9 Y8 Z7 E3 ; XYZ AND EXTRUDE ON EXPANSION BOARD


  • administrators

    1. Did you say that when you connect the DM542 drivers, all axes work? If so, that suggests a problem with the closed loop drives.

    2. Using the breakout board, you should not need to use the R1 parameter in the M569 commands, because inversion of the Enable signal is done by the breakout board.



  • Sorry for confusion and inconvinience,
    The DM542 driver were used in our premises for checking if there any problem in the coding, here no issues were faced while giving the command.
    But now while using the PAS2-4536-1.5N driver at clients place for the X-motor ,the Y-motor and the Z-motor individually, only the Z-axis motor responds while commanding.
    I have also tried connecting each motor to diffrent ports on the expansion board even then only the z-motor work on any port connected.
    On giving 5V supply all the motors lock and does not respond on commanding.


  • administrators

    • What movement commands have you been sending? Only G1 S2 moves with coordinates in relative mode (G91) and homing moves are guaranteed to work before the axes have been homed.
    • Do you get any error messages on the console?
    • After you send the X or Y movement command, do the displayed XY coordinates change in Duet Web Control?
    • Do you have a sensible X and Y steps/mm set?
    • Have you run M584 without parameters to check that the mapping of X and Y axes to external drivers is correct?

    If Z is working, you can check all the drivers by using M584 to map Z to all 3 drives.



  • Is your machine a delta? Set up for delta?



  • @dc42
    Hello,
    I am Prithviraj.poojary. my existing account got spam don't know how, anyway..
    back to your question :-
    •We are sending G28 command,then only Z axis moves to home position Buy other axis are not moving.
    • No we are not getting any Error message in gcode console after sending Command.
    •After sending X or Y movement command, XY coordinates are not changing in display.
    • It is a delta machine and step/mm for XYZ axis are same.
    •Yes we've checked the mapping of X and Y axes to external drivers is correct or not.
    Also for better understanding, on monday i am going to share complete firmware.



  • @edkirk Yes, It is delta machine.



  • Please find the attachment
    0_1553513609044_config.g
    The problem still persists.
    when all the motors connected with thier respective maping, still only the z-axis motor works.
    Please guide with the possible solution


  • administrators

    @devendra-dolas said in Duet expansion breakout board not helping me:

    •We are sending G28 command,then only Z axis moves to home position Buy other axis are not moving.

    Before you try to do that, you should test individual motor movements. See https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareDeltaPrinter#Section_Testing_the_motors_individually.



  • @dc42
    I tested individual motor movements as per your instruction :-
    0_1553593258945_3b73ed48-0a1e-4a5d-b32e-dbdd34790cb8.jpg

    Facing error..


  • administrators

    You forgot to send G91 first.



  • 0_1553607982085_IMG-20190326-WA0011.jpg



  • 1_1553608041791_IMG-20190326-WA0010.jpg 0_1553608041790_IMG-20190326-WA0009.jpg image url)



  • when we connect the motors individually and give home all command they work as expected but when connected all three of them only Z works.


  • administrators

    Did you run the individual motor tests as I suggested? You should also be able to move 2 or 3 motors together, for example to move both X and Y motors you can do this:

    G91
    G1 S2 X10 Y10



  • @dc42
    Yes, i did enter G91 before axis movement. But nothing was changed, axis didn’t move.


  • administrators

    @prithviraj-poojary said in Duet expansion breakout board not helping me:

    @dc42
    Yes, i did enter G91 before axis movement. But nothing was changed, axis didn’t move.

    The error message and the console log that you posted tell me that you didn't. If it's possible to get a motor moving when you try to home the printer, it must be possible to get the same motor moving using G91 followed by a G1 S2 command with an X, Y or Z parameter.

    when we connect the motors individually and give home all command they work as expected but when connected all three of them only Z works.

    That could indicate a problem with the ribbon cable, or with the soldering of the 50-way connector on the Duet or the breakout board. It could also indicate that the PSU that is powering your external drivers can't provide enough current for more than one motor.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.