Duet V0.85 Firmware help.



  • Hey there Duet Community,

    I've been trying to get my rostock max v2 up and running recently, and I'm on the Duet v0.85 motherboard.

    I was on v1.13 up until today, when I decided to update. I tried to update to 1.21 through the web interface, and then went to update the sd card with the updated webinterface folder. I know I did something wrong, because I couldn't connect to it over the web. 😞

    I plugged the Duet in and got the driver installed so now it shows up properly in the device manager, but trying to connect via BOSSA does not work. Using YAT, I tried to get the Duet to respond to an M115 command; it shows that its connected, but just says OK in response.

    Is there a good firmware to start with on the 0.85 motherboard? What can I do to get the Duet V.85 to a working firmware again if I've screwed things up?

    I knew I shouldn't have gone to update the firmware, things were working fine! I appreciate any help given.


  • administrators

    The best firmware to use on a Duet 085 is probably 1.23 available at https://github.com/dc42/RepRapFirmware/releases/tag/2.02. There was a problem with the DHCP client in some earlier releases, which prevented the Duet booting up unless you gave it a static IP address.



  • This post is deleted!


  • I am able to connect to the printer now via pronterface, but still not via the webcontrol. I deleted the /www folder and unzipped the duetwebcontrol v1.22.6 to a new www folder on the usb drive. As a basic check that it's connected, the orange light on the ethernet port should be on, right? Should I be able to ping the printer in the command prompt? Is there a default sys file that I can compare to my current file to make sure I have everything right as far as network goes?


  • administrators

    Check whether the firmware thinks it is connected to the network by sending M552.

    Note, this firmware no longer supports mDNS, so you will have to access the Duet from your browser by quoting either the IP address or the netbios name.



  • Thanks for the help. I got it running, entering the ip address assigned.

    I'm going through the autocalibration process, and noticing some wierd behavior. I initially tried a G30 S-1 command above a bed point, and the probe moved to near the z tower, then between the z and x tower, and dipped like it was changing tooling. Is there something with the updated firmware that I wasn't able to find in the release notes? It's like I need to turn off probe deployment or something, as I'm using FSRs.


  • administrators

    @timonemycat, delete the deployprobe.g and retractprobe.g files in the /sys folder of the SD card.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.