Help List Contents Keep Looping Forever, Crashing Page.



  • Backstory
    Today I've decided to try and get my DuetWifi v1.02 working again.
    I've haven't touched it for a while, and spent last few hours getting back into it before deciding to update the firmware to make sure everything was upto date.

    After reading the firmware github page, I settled for the non-beta, and followed the instructions on how to install.
    I was on 1.19, so didn't have to follow those extra steps.
    I downloaded Release 2.02, "Duet2Firmware-2.02a.zip", and uploaded via the web interface.
    It offered to install it, I chose Yes since I didn't have any more files I wanted to upload. and it got on with it.

    Upon reload, the normal web interface appeared, looking slightly different.

    The Bug....
    My attention was immediately drawn to the User Defined Macros section on the right hand side, which shows the buttons for each macro, however its contents are being populated endlessly over and over again, the same macros in a loop.
    Very quickly that list grows beyond the bottom of the browser window, which makes the scroll bar appear as the page is now longer than the window size.
    The scroll bar handle very quickly 'shrinks', indicating that the list is stuck in a loop where its contents are being repeated in an endless loop.

    The first time this happened, i didn't notice. My browser froze, and I had to End Task to gain control, it wasn't until the second time I realised what had happened.

    Investigation
    To avoid the User Defined Macros list issue, I quickly his settings in hope that the list on the front page would stop populating with repeated items. But tabbing to System Editor gives a surprisingly similar behaviour.
    The system editor page/tab, is also a list of items/objects. And the same error is reproduced, but instead with the list of files in the sys directory of the sd card.
    Constantly looping as though the directory has millions of files with the same name.

    I'm scared, I'm quite computer literate and experienced with programming, but specifically the Duet is something I haven't played with for maybe 2 years now, and I'm concerned I messed up the firmware update.

    I've Tried
    Different browsers... Internet Explorer and Chrome
    Different computer... Mac/Safari... (Same issue, Identical behaviour)

    Some Pics

    Home Screen, Top of List

    4_1553906667289_Duet Issue 1.JPG

    Home Screen, Mid-List

    3_1553906667289_Duet Issue 2.JPG

    Settings/System Editor, Top Of List

    2_1553906667289_Duet Issue 3.JPG

    Settings/System Editor, Mid-List

    1_1553906667289_Duet Issue 4.JPG

    My Current Firmware Versions

    0_1553906667288_Duet Issue 5.JPG


  • administrators



  • That worked perfectly...! Thanks!!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.