Move fast on new axis U for right x carriage



  • I'm using extra U axis on E2_AXIS for the right x carriage.
    When i send G0 F6000 X100 Y100, the X,Y axis can move properly, but when i send G0 F6000 U100 Y100 the u axis move much faster than x axis. The acceleration and jerk for X and U are same. I think it should be caused by the default move axes is X, Y, Z, i dont know how to add a new move axes with the config. Here is my config.g, hope someone can help me. My firmware version is 2.02RC release.
    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S0 ; Drive 4 goes forwards

    M584 X0 Y1 Z2 E3:4 U5 ; create the U axis and assign stepper driver 5 to it
    M350 X256 Y256 Z256 E256:256 U256 I0 ; Configure microstepping without interpolation

    M92 X1280 Y1281 U1280 Z6400 E4350:4350 ; Set steps per mm
    M566 X300 Y300 U300 Z24 E100:100 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000 U9000 Y9000 Z950 E3000:3000 ; Set maximum speeds (mm/min)
    M201 X1500 U1500 Y1500 Z100 E3000:3000 ; Set maximum accelerations (mm/s^2)



  • Hi,

    Are your X, Y and U stepper motors all the same?

    Frederick



  • yes, all the stepper motors are same.


  • administrators

    What stepper driver are you using for E2: the E2 output on a DueX2 or DueX5, or some external stepper driver? If it's an external stepper driver, then the problem is likely to be that the M350 command doesn't apply to it, and you will need to set the U steps/mm in the M92 command according to the actual microstepping used by that driver.

    btw we don't advise using x256 microstepping, because it will limit the speed due to processor overload.



  • @dc42 thank you for your reply, i have fix it by change M563 P1 D1 H2 X3, the old command i use is M563 P1 D1 H2. When define tool 1, i didn't map X movement to the U axis. However, i encounter sevral strange problem after change this command. One of the issues is after switching to tool 1, when i send G1 F200 Z0.5. The right X carriage would move back to about 5 mm around the right endstop. Here is my tool define config:
    ; Tools
    M563 P0 D0 H1 X0 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 X3 ; Define tool 1
    G10 P1 U0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C
    M563 P2 D0:1 H1:2 X0:3 ; Define tool 2
    M567 P2 E1.0:1.0 ; define mix ratio for tool 2
    G10 P2 X0 U0 Y0 Z0 ; Set tool 2 axis offsets
    G10 P2 R0 S0 ; Set initial tool 2 active and standby temperatures to 0C

    Could you explain how the right X carriage move after map to X movement, thank you very much



  • After a day of trying, I found the cause is after switching to tool 1, i used to send "G0 F6000 U100 Y10". But after mapping X movement to U axis, i need to change the command back to "G0 F6000 X100 Y10", it didn't need to replace X with U anymore. So the new question is how to manager the command for duplicate mode, the old command for duplicate command like "G0 F6000 X100 U200 Y0".


  • administrators



  • @dc42 Thank you , i have fixed it.😁


  • administrators

    btw it's also possible to print in mirror mode. The procedure is:

    1. Adjust your M208 and other settings so that X0 Y0 is bed centre (this works better for duplicate mode too, because all your prints can be centred at (0,0) when you slice them, regardless of how you intend to print them).

    2. Use the M579 command to apply a scaling factor of -1 to the U axis during the print.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.