Z-Offset increasing with every print



  • Hi!

    My Z-Offset is increasing about 1mm with ever print. If I restart the firmware, it is not increasing.
    The heatmap is under the Z= level - may be this has to do with the problem?

    Setup:
    Duet Wifi, Slicer S3D
    Bed leveling is done with two optical Z-min endstops and two steppers - working fine.
    Than the stored heatmap is used vor auto bed leveling.

    Autobed leveling is done with a precision piezo orion probe.

    config.g:
    ; Z-Probe
    M558 P8 I1 R0.4 F300 T10000 H1 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z0 ; Set Z probe trigger value
    ; Endstops - empty

    The sequences before printing are:

    Set the Z-offset in homeall.g and homez.g
    G92 Z4.66 ; Z offset (positive is closer to bed)

    In the S3D start-script home all axis and activate bedleveling with the stored heatmap:
    G28 ; home all axes (homeall.g)
    G29 S1 ; enable mesh grid compensation from saved file

    Any ideas?



  • Can you post your homing files?

    Are you using a probe to home Z or the end stops? Setting the Z height with G92 isn't needed if you're homing with the probe.

    G31 Z0 doesn't seem right for the Piezo. It will likely have a small negative value since it's a nozzle contact probe. You'll need to calibrate your trigger height with this: https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • For homing and bed tilt leveling I use the endstops. The probe is only used for mesh bed leveling from time to time.
    I thought, the Z-offset of the probe does not matter, because the probe is only used for generating the heightmap and leveling is done by the endstops, anyway.

    ; homez.g
    G91
    M584 Z2 U4 P4. ; split Z motor control to Z and U for it to work we have to show U (param P4) in the UI
    G1 S2 Z6 U6 F6000 ; move bed down 6mm
    G1 S1 Z-300 U-300 F4000 ; move quickly to Z axis endstops and stop there (first pass)
    G1 Z2 U3 F4000 ; go back a few mm
    G1 S1 Z-300 U-300 F300 ; move slowly to Z axis endstops once more (second pass)
    M584 Z2:4 P3. ; back to combined axes and hidden U
    G90 ; Back to absolute positioning
    G92 Z4.66 ; Z offset (positive is closer to bed)
    G91
    G1 Z5 F3000 ; lift Z after probing
    G90



  • If I were you, I would split the independant Z axis leveling out into bed.g and use G32 to call for that. And then use the probe to home the Z axis in homeall.g and homez.g (G28). Even if you wanted to do the leveling routine each time you homed, you could simply add G32 to the start of your homeall.g and then use G30 to set your Z height.

    The G31 Z offset does matter for the heightmap. Having an inaccurate value there would explain why your heightmap is off.

    As you have it now you have two possibly inaccurate ways of setting the Z height interacting. G92 Z4.66, which may not be accurate, and then G31 Z0, which is probably not accurate creating the heightmap.



  • Also, what firmware version are you running?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.