Duet Wifi Stuck on Processing



  • Hey all, I've got a Duet Wifi that is seemingly not able to upload prints over wifi, likes to give errors when uploading .g files over wifi, and most frustratingly, gets stuck on "Processing" after I've selected a print on the MicroSD card. I have never had it upload a file over wifi after a week of tinkering, pre-fw update and post update, over two MicroSD Cards. I am using no adapters on the microsd cards, and the board does have a fan on it to keep things cool.

    It's running the 2.03Beta3 firmware, Wifi Server ver. 1.23, and Web Interface Version 1.22.6. I have tested this issue with Chrome and Firefox with no improvement, and I have tried a known good MicroSD card and the original one it came with.

    If I could get some pointers on what to test to narrow down my issues, it would be greatly appreciated.



  • What do the errors on upload say?
    Can you post the results of an M122 diagnostics report?
    And M39 to get some information about your SD card.
    SD card should be formatted to FAT16 or FAT32 with 64kb cluster size.



  • I'm unsure of what the errors say each time it fails on upload. Is there a way to check them? I'll go to upload a file and it'll either load one percent, hang, then display "ERROR" across the loading bar, or it'll load a little bit, then just display "ERROR" on the bar. Sd card 2 is the original. I have more I'll try now that I know the other known good one, is not good due to the cluster size.

    EDIT: Tried with 3rd Microsd card, M39 report of:
    SD card in slot 0: capacity 7.99Gb, free space 7.95Gb, speed 20.00MBytes/sec, cluster size 64kb
    3rd microsd card let me upload a file to 3%, then it gave me the error. Further than i've gotten, but still not far enough.

    SD Card M39 report 1:
    M39
    SD card in slot 0: capacity 1.99Gb, free space 1.94Gb, speed 20.00MBytes/sec, cluster size 4kb

    SD Card M39 Report 2:
    SD card in slot 0: capacity 3.98Gb, free space 3.89Gb, speed 20.00MBytes/sec, cluster size 64kb

    M122 Diag Report Results:
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.03beta3 running on Duet WiFi 1.02 or later
    Board ID: 08DGM-917DA-G4MSD-6JKD0-3S06S-K9VBA
    Used output buffers: 3 of 20 (10 max)
    === RTOS ===
    Static ram: 25632
    Dynamic ram: 93844 of which 0 recycled
    Exception stack ram used: 292
    Never used ram: 11304
    Tasks: NETWORK(ready,524) HEAT(blocked,1236) MAIN(running,3744) IDLE(ready,196)
    Owned mutexes:
    === Platform ===
    Last reset 21:37:50 ago, cause: software
    Last software reset at 2019-04-15 19:45, reason: User, spinning module GCodes, available RAM 11080 bytes (slot 2)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 16
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 260.8ms, max retries 0
    MCU temperature: min 33.2, current 33.5, max 36.0
    Supply voltage: min 0.4, current 12.1, max 12.6, under voltage events: 1, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-04-16 17:23:20
    Cache data hit count 4294967295
    Slowest loop: 555.98ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, FreeDm: 169, MinFreeDm: 169, MaxWait: 0ms
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === MainDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0, aux move: no
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 739.19ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address cc:50:e3:0d:28:23
      WiFi Vcc 3.41, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 24040
      WiFi IP address 192.168.0.171
      WiFi signal strength -61dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0


  • @wobwob said in Duet Wifi Stuck on Processing:

    WiFi signal strength -61dBm

    That's not awful signal strength, but it can vary a lot from time to time and there could be enough interference in the area to make it drop substantially at times.

    As a test, if possible, move the printer or router into the same room and test again. What kind of router is it by the way?

    You may find something here as well: https://duet3d.dozuki.com/Wiki/WiFi_disconnections_and_AJAX_timeout_errors



  • Router is a "Cox Panasonic" router, just the normal one they give out. I'm gonna have to make some sort of interim network for this to run on, but that's not an issue. Turns out once I replaced it with a MicroSD card set to the proper cluster size, it processes! Web interface froze on me once, but it's printing from a 70mb file right now, and I got it to at least start a 150mb file. Now back to battling my bed adhesion issues. Thank you everyone for your help!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.