Limit switch/end stop ignoring



  • We have a printer that has 360 degree rotation (3D Potter Scara) and would like to have it ignore a probe switch after it has homed. We are wondering if this should be a setting in the homing files or in the config. We are looking at the M581 command but can not seem to get it right.

    Currently only the main rotating base (Distal Arm, X) stops moving when the probe switch is triggered again, and will not move until the the print is stopped and it receives a new command to home again. We have tried many variations of M581.
    The Prox arm, Y, does ignore its own probe switch after homing. We would like it to actually obey it, and not cross over it after it has homed, (currently what the Distal Arm is doing).

    Config settings we have been working with:
    M574 X1 Y1 Z2 S0 ; Endstop configuration
    M581 Z1 S1 C1 ; Configure external trigger
    M581 X S-1 ; Configure external trigger

    Our current config: https://pastebin.com/yA4Nap2w



  • Made a video of the problem.

    https://www.youtube.com/watch?v=tlsul1eGThI

    I have read this post: https://forum.duet3d.com/topic/33/end-stops-and-limit-switches but it did not solve the problem. I have tried no M581 commands in the config and it acts the same, as shown in the video.


  • Moderator

    Is it the SCARA kinematics that require using M581 as additional endstops?

    Can you post your homing files?

    You have M581 X S-1 ; Configure external trigger in your config.g to ignore that trigger, but I would think you would want that in your homing file to start ignoring it after it's been used. No?


  • administrators

    @3DPotter, RRF ignores homing switches on all moves that don't invoke them explicitly (i.e. G0 and G1 moves with the S1 or S3 parameter). So what I think it happening is that RRF hasn't recognised that your proximal axis is a continuous rotation axis. Therefore it is taking the values in the A parameter of the M667 command as proximal angle limits.

    Has this ever worked for you? Which firmware version are you running?

    What happens if you change your M667 A parameter from A-180:180 to A-180:181 ?



  • Changing the M667 parameter to A-180:181 worked. Thank you.🙂


Log in to reply