Filament monitor too much movement



  • I have a beta test filament monitor that works like a charm and saved me from a lot of failed print.
    Sometimes I have fake error " extruder reported too much movments"
    My sensors report

    Extruder 0 sensor: position 192.30, ok, 0 framing errors, measured sensitivity 23.02mm/rev, measured minimum 118%, maximum 134% over 1045.6mm

    Minimum and maximum stay quite stable but always in the + side and always about 118/130
    I suppose it should stay between +or - 10% . It seems to me , if I understand correctly , that the variation in measures is good but the firmware think that the filaments always move too much.
    Is the sensitivity set wrong ? How can I correct it?

    FIrmware 1.21 duet 2 wifi corexy direct titan extruder
    M591 D Duet3D rotating magnet filament monitor on endstop input 3, enabled, sensitivity 28.80mm/rev, allowed movement 20% to 160%, check every 3.0mm, current position 249.3, measured sensitivity 23.01mm/rev, measured minimum 118%, maximum 134% over 932.8mm
    config.g string M591 D0 P3 S24.5 C3 R20 E3.0


  • administrators

    Firmware 1.21 is quite old so I suggest you upgrade it to 2.02. The parameters to the M591 command have changed so see the entry for M591 on the GCodes page of the wiki. That also covers adjusting the sensitivity.



  • Ops I made a mistake 1.21 was the wifi server version I am on 2.02RC3(RTOS) (2018-10-17b2)
    I'll take a look to the gcode page anyway maybe I'll find a solution there if not I'll report 🙂
    Thx



  • I just got my filament monitor earlier this week. I've got it hooked up and I'm calibrating now. I'm seeing similar readings. I've got my extruder nicely calibrated, any idea what is going on?

    12:37:04 PMM591 D0
    Duet3D laser filament monitor on input 3, disabled, allow 40% to 120%, check every 3.0mm, current pos -4.5, brightness 128, shutter 35, measured min 158% avg 179% max 191% over 1802.9mm

    Software Information
    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.6
    Web Interface by Christian Hammacher
    Licensed under the terms of the GPL v3


  • administrators

    I think you have the new version laser filament monitor because you are getting much more than 100% movement. You need to run firmware 2.03beta to support it properly.



  • @dc42 I'll give that a try.



  • That seems a nice improvement:

    9‎:‎47‎:‎34‎ ‎PM
    M591 D0
    Duet3D laser filament monitor v2 on input 3, disabled, allow 150% to 200%, check every 3.0mm, current pos 0.8, brightness 29, shutter 133, quality 221, measured min 80% avg 89% max 96% over 761.6mm



  • And here is the new software version just to be complete:

    Software Information
    Firmware Name:
    RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics:
    Duet WiFi 1.02 or later
    Firmware Version:
    2.03beta3 (2019-03-25b6)
    WiFi Server Version:
    1.23
    Web Interface Version:
    1.22.6
    Web Interface by Christian Hammacher
    Licensed under the terms of the GPL v3



  • I'm getting the too much movement when enabled.
    I'm running Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.03RC2 (2019-05-14b2)
    I have M591 D0 P5 C3 R40:130 E3.0 S0 in config,g what is the problem?
    Should I use R140:220??
    It say version 1 but i'm not sure is there a way to check the board to see what version it is?

    Duet3D laser filament monitor v1 on input 3, disabled, allow 40% to 130%, check every 3.0mm, current pos 4.4, brightness 93, shutter 3, measured min 160% avg 185% max 203% over 540.4mm
    Duet3D laser filament monitor v1 on input 3, disabled, allow 40% to 130%, check every 3.0mm, current pos -9.7, brightness 70, shutter 11, measured min 156% avg 185% max 199% over 1365.7mm

    Thanks for any help


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.