Cloned extruder



  • Hello 🙂

    I need a second extruder motor that performs the same movements as of the first one. No Hotend or Thermistors, just the extrusion. Is it somehow possible to setup the second extruder driver E1 to run synchronized to E0?

    I'm using a Duet Maestro. The second motor will just help the first one with the extrusion and also eliminates the problem that my y axis gets lift up by a heavy filament role.



  • the easiest solution is to connect the stepper motors in parallel.



  • I've thought about it but can't risk overburden the driver. Also I don't have two similar motors as one is a very lightweight direct drive extruder motor and the other one strong one. Thus I prefer a second driver software solution.



  • https://reprap.org/wiki/G-code#M584:_Set_drive_mapping should do the job if you have a stepper channel to spare.



  • @mike That's great! I was looking for exact such thing but have obviously overseen it! I will try that. Thanks! 🙂

    In case of any Duet specific changes to that M584 command here the reference from Duet GCode: https://duet3d.dozuki.com/Wiki/Gcode#Section_M584_Set_drive_mapping



  • It works. The only problem is that I now need to post-process my gcode to have the other extruder printed out as well:

    G1 X4 Y0 E0.5 => G1 X4 Y0 E0.5:0.5

    Despite of M584 I also had to modify some other commands (relevant parts are the extensions with :NN behind all extruder/ tool parameters for the second extruder/driver) :

    M584 X0 Y1 Z2 E3:4				; Both drivers 3 and 4 are extruders
    M92 X80 Y80 Z80 E842:80				; Steps per mm (now also for second extruder)
    M906 X500 Y500 Z500 E1000:500 I60		; Set motor currents (mA) (now also for second extruder)
    M201 X1000 Y1000 Z1000 E1000:1000		; Accelerations (mm/s^2) (now also for second extruder)
    M203 X2000 Y2000 Z2000 E2000:2000		; Maximum speeds (mm/min) (now also for second extruder)
    M566 X1200 Y1200 Z1200 E1200:1200		; Maximum instant speed changes mm/minute (now also for second extruder)
    M563 P0 D0:1 H1					; Define tool 0 (Enable both extruders 0 and 1)
    


  • @ted A better way to do what you want is to define your tool to use both extruders. I'm in another country right now and have very poor internet access and just my phone so it's difficult for me to tell you the exact commands. But in you tool definition use D0:1 instead of just D0. Then set mixing ratio to 1.0:1.0. That will use both extruders in equal amounts for the tool, so you won't have to any post processing of the gcode files.


  • administrators

    @ted said in Cloned extruder:

    It works. The only problem is that I now need to post-process my gcode to have the other extruder printed out as well:
    G1 X4 Y0 E0.5 => G1 X4 Y0 E0.5:0.5

    You don't need to do that if you send this command:

    M567 P0 E1:1

    That enables mixing on tool 0 with the mixing ratio set to 1:1. So G1 E0.5 will advance both extruders by 0.5mm.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.