ELI5 How to correctly set up my probe.



  • I've had such a pain setting up my probe. First it just won't respect baby stepping whatsoever. I have another printer with a Duet Maestro and BL Touch and it seems to work just fine. This Prusa running a pinda is just angry at me.

    My setup: A custom prusa mk3 with Duet 2 latest board 1.04b.

    I have a Pinda 1 installed in the Z end stop port for ease of use. This is my setting to make sure its read as the z end stop and the probe.

    M558 P4 C2 H5 I0 F600 T3000 A3

    I then homed the printer and used the guide to calibrate the trigger height. I made sure all values were 0 and then sent M564 S0 so I could get the nozzle to the bed. Sent G92 Z=0 to save the location where Z = 0. Followed that up by doing 5-6 lift Z 5 to 10mm and sending G30 S-1 and ended up with a value around 1.2mm.

    G31 P500 X0 Y0 Z1.2

    So what did I get for that?? Nozzle would immediately crash into the bed gouging everything.

    I spent time working with others who know duet more than I and to no end this setup just will not work correctly. Either the nozzle is a million miles (1-2mm) above the bed at the start of the print or 1-2mm into the bed. I'll set baby stepping to get the first layer going great and the next immediate print will start exactly where the last print started so in the bed or floating too far above.

    Someone please save me a headache.

    Also WHY doesn't duet have a confirmation of first layer settings? We plug all these settings in I'd love a way for the printer to go exactly to Z=0 and confirm it knows what it's doing before a print this way I don't destroy everything in it's path. I had the same issue on the maestro Ender 5 build. It just DOES NOT respect the values using this method so I'd love a way to know how to correctly set this up without destroying half my printer.



  • I'm not super familiar with the PINDA, other than it's an inductive sensor, but as a sanity check...

    Can you include some more information so we can see what's actually happening with your macros? Config.g, and homing files would be helpful.

    Also, can you verify your firmware versions?

    Your M558 command looks ok. Your G31 should have an X and Y offset so that the probe to nozzle distance is known.

    Your test procedure to measure the trigger height sounds right. When you do the repeated tests are you getting good repeatability?

    Are you using mesh compensation as well?

    @codiac2600 said in ELI5 How to correctly set up my probe.:

    We plug all these settings in I'd love a way for the printer to go exactly to Z=0 and confirm it knows what it's doing before a print this way I don't destroy everything in it's path

    You could do that if you wanted.

    in start.g in the sys folder, which gets run before any slicer start gcode when a print is run you could have it do

    G28 ; home all axis
    G90 ; absolute positioning
    G1 Z1 ; move nozzle to what should be 1mm above the bed
    M291 S3 Z1 R"Adjust Z Axis" P"Jog the Z axis until the nozzle is just touching the bed" ; pop up a Z axis jogging prompt
    G92 Z0 ; reset Z0
    

    But at that point you might as well use manual probing.


  • administrators

    @codiac2600 said in ELI5 How to correctly set up my probe.:

    So what did I get for that?? Nozzle would immediately crash into the bed gouging everything.

    When you did what?

    Also WHY doesn't duet have a confirmation of first layer settings?

    Please explain what you mean by "a confirmation of first layer settings".


Log in to reply