"Wifi reported error: wrong password..." - it worked before



  • This is on my converted Wanhao D5S Mini (running DuetWifi 1.03 mainboard with latest stable firmware and Wifi Server). I have performed the update to use an external antenna (since the D5S Mini is a metal box), and for the past year, little over a year, the machine have worked.

    The Access Point is right next to the printer (less than 50cm), and also the details was not changed at all.

    When I am logged into the AP management, I can see that my printer is shown as connected, yet the Duet (on the PanelDue Console) reports being unable to connect due to a wrong password. After many connection attempts, it sometimes managed to connect (but the connection was unreliable)

    I have since commanded it to forget all known networks, and added the access point again - this result in the printer simply being unable to connect (according to its console), but still the AP report it as being connected.


  • administrators

    First, make sure that you don't have a M587 command in your config.g file. M587 should never be used in config.g, yet I see users publish config.g files containing M587 commands. Every time you use M587 to add an access point name, it writes to flash memory on the WiFi module, and the flash memory can handle a limited number of writes.

    In case the area of flash memory containing the password is flaky, try clearing out the access point names again, then add one or two dummy access point names to use up the first one or two slots; then add the real one. Don't forget that most GCode sender programs convert all characters to uppercase, so use YAT or another terminal emulator to send the M587 command.

    If that doesn't work, and re-flashing DuetWiFiServer 1.23 doesn't help, then I suggest you replace the ESP module again.

    HTH David



  • Thank you; using the dummy access points worked - it is now connected, and connection is stable.

    I confirm I have removed the M587 from my config.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.