X Not moving when homing



  • Hi Guys, So i have a bit of a weird issue.
    So. I got my printer priting well enough for now. Configured all the motors etc. Got it printing as best i could however because of my BL touch, the printer started printing off center. In a effort to fix this i changed the offset to the z prob in the config from -18 to 18. This resulted in the homing, going to x endstop then dropping. I then have to do a emergency stop before it hits the bed.

    From what i remember this is the only value i changed. I've changed it back to -18, 18, 30, -30 to see what happens and so far its just done nothing bar drop.

    Here is my Config.
    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"Jack" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X160.00 Y160.00 Z800.00 E399.04 ; Set steps per mm
    M566 X600.00 Y600.00 Z180.00 E399.04 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X500.00 Y500.00 Z500.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X30 Y-10 Z0 S1 ; Set axis minima
    M208 X220 Y220 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T1500 ; Set Z probe type to bltouch and the dive height + speeds

    G31 P1 X-18 Y0 Z0.679 ; Set Z probe trigger value, offset and trigger height

    M557 X20:200 Y20:200 S40 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; Set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275 ; Set temperature limit for heater 1 to 275C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool

    Thanks for the help



  • post all your homing scripts



  • Hi, They are..

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 13 2019 16:24:08 GMT+0100 (British Summer Time)
    G91 ; relative positioning
    G1 Z0 F1500 S2 ; lift Z relative to current position
    G1 S1 X-258 Y-235 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F1500 ; go back a few mm
    G1 S1 X-258 Y-235 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X20 Y20 F1500 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F25 ; lift Z relative to current position
    ;G90 ; absolute positioning

    ; homex.g
    ; called to home the X axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 13 2019 16:24:08 GMT+0100 (British Summer Time)
    G91 ; relative positioning
    G1 Z5 F1500 S2 ; lift Z relative to current position
    G1 S1 X-258 F1800 ; move quickly to X axis endstop and stop there (first pass)
    G1 X5 F1500 ; go back a few mm
    G1 S1 X-258 F360 ; move slowly to X axis endstop once more (second pass)
    G1 Z-5 F1500 S2 ; lower Z again
    G90 ; absolute positioning

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 13 2019 16:24:08 GMT+0100 (British Summer Time)
    G91 ; relative positioning
    G1 Z5 F1500 S2 ; lift Z relative to current position
    G1 S1 Y-235 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F1500 ; go back a few mm
    G1 S1 Y-235 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-5 F1500 S2 ; lower Z again
    G90 ; absolute positioning

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Apr 13 2019 16:24:08 GMT+0100 (British Summer Time)
    G91 ; relative positioning
    G1 Z0 F1500 S2 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X20 Y20 F1500 ; go to first probe point
    G30 ; home Z by probing the bed
    ;
    ;G30 ; Do a single probe to home our Z axis
    ;G90 ; Make sure we are in absolute mode
    ;G1 Z5 F6000 ; Rapidly move the Z axis to Z=10.
    ;
    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F25 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • @jackismad said in X Not moving when homing:

    M557 X20:200 Y20:200 S40 ; Define mesh grid

    you need to move the grid as well by the 36 you have moved the offset



  • That makes sense! I've changed the value in x for the M557 Command to 56.
    However i still have the same issue. The X Will home, will stay where the endstop is then deploy probe and then Z will lower



  • @jackismad said in X Not moving when homing:

    M208 X30 Y-10 Z0 S1 ; Set axis minima

    this also seems wrong.

    this will prevent any movement below X30. you prob want X0 here



  • there should have been a message about this in the console log.



  • You, Legend! Its working, Not sure why i changed that, I did look in my console log but the only error is the Z probe failed to deploy, this was made when i emergency stopped.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.