entire bed too high or too low



  • 0_1557665262516_bed-too-high.png

    I have seen this condition with the entire bed too high or too low before, but I cannot understand what the configuration or error is that generates it. Normally I just keep fiddling and the problem goes away, but I would like to know where to look to address it.

    It seems like it should not be possible? This is on a delta with a mini-IR sensor, glass bed covered with blue painter's tape. After running G32 the result is:

    3:15:05 PM G32
    Calibrated 6 factors using 10 points, deviation before 2.712 after 0.056
    

    Going to bed centre Z=0 puts the nozzle on the bed with reasonable drag on a sheet of paper. The mesh calculation is run without re-homing the carriage, but just tried with re-homing and the result is the same.

    So what can cause the mesh compensation result to be entirely shifted up or down?



  • Check your probe trigger height. Its likely off by 0.8mm as indicated by the mean error?

    Z parameter here https://duet3d.dozuki.com/Wiki/Gcode#Section_G31_Set_or_Report_Current_Probe_status



  • As in the original post, going to z=0 puts reasonable drag on a sheet of paper following g32 or just re-homing. I set this with g31:

    G31 P500 X-9 Y20 Z1.600    ; Z probe trigger value, probe offset from nozzle (lower val raises nozzle) and trigger height - glass
    

    Also, this just sets the physical distance between the nozzle tip and the Z-probe trigger point - so (without physically crashing the nozzle and causing skipped steps and bed damage) the mesh software doesn't know any more than what the probe tells it?


  • administrators

    How are you homing Z? One cause of getting a height map like would be that you are homing the bed using a homing switch; but the Z=0 position defined by the homing switch is not the same height as the Z=0 position defoned by the Z probe.



  • Thanks David, indeed that fixed it - although my 'extra careful' measurement was only 2mm off from what I originally had for the M665 H parameter.


  • administrators

    @robm said in entire bed too high or too low:

    Thanks David, indeed that fixed it - although my 'extra careful' measurement was only 2mm off from what I originally had for the M665 H parameter.

    If you have a delta, then before running mesh probing, you should run auto calibration and save the parameters, either by sending M500 if you are using config-override.g, or by editing them into the M665 and M666 commands in config.g if you are not.



  • Ah! Thanks again, I (clearly) missed that trick to get measured values.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.