DuetWifi 2 Fan configuration



  • I recently acquired a machine from a friend and did not redo his wiring, so thats why the connections are a bit off.
    I upgraded the firmware from v1.79 to v.2.02b, after i accidentally erased the firmware off the chip.

    I ran into problems with my hotend cooling fan (it would often turn off when starting a print), which resulted in me having to disassemble the Titan Aero and melting out the plastic which was clogging my coldend.
    This is the main reason i want to reconfigure my fans.

    Currently I'm running no part cooling, but im planning on addidng this in the future.
    Current connections are:
    Hotend-Fan on FAN0 and the old part-cooling-fan was connected to FAN1
    I read that these connections should usually be the other way around and my guess is, this caused the fan to turn off.

    I want to switch these connections back to the default configuration (part cooling on FAN0 and hotend-fan on FAN1) and setting the hotend fan to be thermostatically controlled, but after upgrading to v2.02b I now have the "Tool Fan" slider in the DWC, which IS indeed controlling the hotend fan so FAN0.

    How do I change this in the settings, so FAN1 is now recognized as "Tool Fan"?
    Or am I mistaken and "Tool Fan" refers to the part cooling fan?

    Current fan configuration in config.g:

    ; Fans
    M106 P0 S0.7 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F100 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    My guess is that my new fan configuration, if I want to turn on the hotend-fan at 70%, once the hotend reaches temp above 45°C should like like this?

    ; Fans
    M106 P0 S0.7 I0 F250 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0.7 I0 F250 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    Thanks in advance for your help.

    Random information:
    Firmware Version: 2.02b
    Hardware Version: Duet2 V1.03

    Best Regards, JV


  • administrators

    The Tool Fan means the same thing as the Part Cooling Fan.

    My guess is that my new fan configuration, if I want to turn on the hotend-fan at 70%, once the hotend reaches temp above 45°C should like like this?

    ; Fans
    M106 P0 S0.7 I0 F250 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0.7 I0 F250 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    That's OK so far, but also check whether your M563 tool definition commands have F parameters. You don't need those parameters if fan 0 is the part cooling fan/tool fan.



  • Thanks for the quick response

    M563 does not have any parameters except for Tool number, Heater/Extruder mapping.
    In this case i should not be required to adjust my proposed new config?

    As you can see, I'm planning to reset the PWM frequency to default, this should work fine, as long as the PWM control works satisfactory right?

    Again thanks for your amazingly fast help, you're a legend!


  • administrators

    @jv43 said in DuetWifi 2 Fan configuration:

    M563 does not have any parameters except for Tool number, Heater/Extruder mapping.
    In this case i should not be required to adjust my proposed new config?

    Correct, if you have only one part cooling fan and it is Fan 0 then you don't need to use fan mapping parameters in M563 commands.

    As you can see, I'm planning to reset the PWM frequency to default, this should work fine, as long as the PWM control works satisfactory right?

    Yes. Note, E3D hot end fans don't work well with PWM at all, they need to be fully on or off.



  • @dc42

    Note, E3D hot end fans don't work well with PWM at all, they need to be fully on or off.

    I'm not having any problems, 70% runs fast enough to avoid overheating the coldend and is noticeably quieter than running at full speed.
    Are there any adverse effects hardware-wise, caused due to running the fan not at max speed, I should be aware of or is it safe running at my current settings?


  • administrators

    @jv43 said in DuetWifi 2 Fan configuration:

    @dc42

    Note, E3D hot end fans don't work well with PWM at all, they need to be fully on or off.

    I'm not having any problems, 70% runs fast enough to avoid overheating the coldend and is noticeably quieter than running at full speed.
    Are there any adverse effects hardware-wise, caused due to running the fan not at max speed, I should be aware of or is it safe running at my current settings?

    That should be safe, if you are certain that the heatsink cooling is sufficient.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.