G30 works autocalibration tilts before it gets a trigger



  • Hi All, figured i'd ask here before i break something (again).

    so after issues with my BLTouch and getting the printer working without a probe i decided to order a smart effector. its all wired up and G30 works great, but when i try to do the delta autocalibraion, it touches the bed and starts tilting the effector before the probe triggers.

    Video of the issue
    https://youtu.be/SK9TI8eFZxg

    the printer is a SeeMeCNC Rostock mk2 with an e3d volcano, smart effector and for now a 3d printed adapter until my aluminum one from maker 713 arrives.

    what am i doing wrong?
    thanks
    Raptor

    Config
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Wed May 15 2019 08:59:39 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M665 R119.761 L291.06 B134 H306‬ ; Set delta radius, diagonal rod length, printable radius and homed height 360.677 was old h
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 P"Rostock mk2" ; Set machine name
    M552 S1 ; Enable network
    M587 S"Wifi" P"password" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Physical drive 0 goes forwards
    M569 P1 S1 ; Physical drive 1 goes forwards
    M569 P2 S1 ; Physical drive 2 goes forwards
    M569 P3 S1 ; Physical drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E92.40 ; Set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X15000 Y15000 Z15000 E15000 ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 Z3000 E3000 ; Set accelerations (mm/s^2)
    ;M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; Set maximum speeds (mm/min)
    ;M201 X1000.00 Y1000.00 Z1000.00 E1000.00 ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1000.00 E900.00 I60 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    ;M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P8 R0.4 F400 ; Set Z probe type to bltouch and the dive height + speeds
    M558 H30 ;*** Remove this line after delta calibration has been done and new delta parameters have been saved
    G31 P100 X0 Y0 Z-0.1 ; Set Z probe trigger value, offset and trigger height
    ;G31 P9 X18.38 Y-10.62 Z0 ; Set Z probe trigger value, offset and trigger height
    M557 R134 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 ; Part Cooling Fan
    M106 P1 T60 s0.7 H1 ; Heat sink fan
    M106 P2 ; Case fan

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory


  • administrators

    F400 in Your M558 command is too low. Use F1200 as advised at https://duet3d.dozuki.com/Wiki/Smart_effector_and_carriage_adapters_for_delta_printer#Section_Commissioning.

    If the nozzle is cold, then you should see the green LED flash if you tap upwards on the nozzole with your fingers. Note, you may need to wait about 15 seconds after power up before the electronics has stabilised and the effector reacts with normal sensitivity.



  • that fixed it, thanks,

    i think i copied it the first time without the last 0 on 1200 because i had upped it from 120 to 400 because i thought it was too slow!

    its working great now, thanks


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.