Did I just fry my Maestro?



  • Heyo Guys,
    A while back I upgraded my Anet A8 (https://all3dp.com/1/anet-a8-3d-printer-review-diy-kit/) with a Duet Maestro and everything was going pretty well.
    Some days ago I decided to check why my part cooling fan wasn't working and checked the FAN0 connections with the Multimeter I barely know how to use. Somehow I touched something else while checking (I believe it was the FAN1 connection, but I'm not sure) and after that my two Z-Axis stepper stopped working properly. They were moving a bit forward and back, while making nasty clicking sounds. Now they don't react at all anymore and I'm kinda scared that I might've fried the board. I connected the Y-Axis to the Z port and there still wasn't any movement, so I think that the stepper are probably fine.
    I tried to check with my Multimeter, but frankly I am to stupid to figure out what to do.
    0_1559151710655_config.g
    I hope it is just some problem in my config file, wouldn't be the first time some stuff changes by itself, but I don't have high hopes.

    Does anyone care to help me?



  • Odd set of symptoms; sounds like bad wiring to me?

    Power off the board, unplug the two z steppers and measure the resistance between pin 1 & 2, and between 3 & 4 on each stepper cable, and give it a close inspection to see if there are any loose contacts?



  • I don't know what you just did, but after I redid my wiring it now works again. Thing is, I could've sworn all wires were secured properly
    For the record, I had about 5.4 on the lowest (200) Ohm setting of my Multimeter for all the wires.

    I could kiss you right now, thank you.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.