PanelDue 7i blank screen after firmware update



  • I bought a Duet3D version of the integrated PanelDue 7i back in February, and saw that newer firmware was available from DC42. I followed the instructions on David Crocker's Solutions blog, used the 1.9.1 Bossa program to burn version 1.23.2 firmware (a 164KB image named PanelDue-5.0i-7.0i.bin).

    It appears to have worked (Bossa writes and verifies the image successfully), but the screen is blank. The LCD's backlight is on, but the screen is dark. The Erase button does nothing when pressed or held. The reset button appears to reset the USB comms. It behaves the same whether it's on USB alone, connected to a Duet, or powered standalone from a bench supply.

    The Bossa program doesn't adapt to non-standard font size, and the UI is difficult to use as a result, so I tried Bossac at the latest release (1.7.0) but it fails on verify. Apparently, that's a known issue.

    I tried the two most current firmware releases, both logo and nologo.

    What else should I check?

    Is there a more correct way to update the firmware?



  • The Erase button will erase the firmware you just loaded leaving you with no firmware installed.
    You should not need to press the erase button.


  • administrators

    Did you remember to check the Erase All, Boot To Flash, and Lock boxes when you flashed the firmware? Or used the equivalent command line options when running bossac.

    I've not heard of failing on verify being a "known issue". Verify certainly works in Bossa, I use it all the time. It would fail if you also checked Security.



  • That makes sense.

    I only press it as part of the firmware update though. It's part of Crocker's instructions.



  • @dc42 Thanks. I did not check those boxes but will try that when I'm done typing. I followed the instructions to the letter with bossac, and I see no instructions for using the GUI on the blog, presumably because of the visual issues of the GUI.

    I'd MUCH rather use command line anyway.

    Thanks again.



  • That solved it. Thank you sir!



  • @giblte535 Note for trying to use bossac:

    The -e option in the instructions will fail if the firmware was erased with the button.

    But here is what I was talking about with the bossac problem. Verify fails and the screen stays blank.

    $ ./bossac.exe --port=COM13 -w -v -b PanelDue-5.0i-7.0i.bin
    Atmel SMART device 0x289b09e0 found

    Write 168276 bytes to flash (329 pages)
    [==============================] 100% (329/329 pages)
    done in 4.156 seconds

    Verify 168276 bytes of flash
    [==============================] 100% (329/329 pages)
    Verify failed
    Page errors: 297
    Byte errors: 145433

    If I dig into the source and figure out why that is, I'll update this post. Thank you again!


  • administrators

    Thanks. I wasn't aware that there were still issues with the GUI version of Bossa on certain monitors. I know there was an issue with version 1.8 on high dpi monitors, but I was told that version 1.9 fixed that.


Log in to reply