Flashing BLTouch



  • I have posted about this on the RepRap forum, but probable should have started here.

    Duet WiFi, 24v, CoreXY.

    I am having a problem with BLTouch. It was working perfectly for a couple of weeks and then started flashing and became unresponsive. On the reprap forum, it was suggested that the voltages might be off but I checked and I have a consistent 5.01v on the red wire and 3.28v on the white wire which I think is within spec. I was printing just fine before this started. When I couldn’t figure anything out, I swapped the flashing BLt for another and seemed to be working. I started going through the calibration step in the duet docs and after running G30 S-1, the new one started flashing and now it to is unresponsive. Cycling power does nothing.

    Either I have just blown a second BLt, or the problem is not with the device. Can anyone offer some help?



  • Additional info: came back from dinner and powered up the duet. The BLtouch was not flashing but I tried to home z and the bed rose but the BLTouch did not deploy. I then tried g30 and got the message that the probe was already triggered at the start of the probing.



  • Considering that it seems to happen across multiple BLTouch I would focus on checking the wiring. Either a bad crimp or intermittent failure.



  • Yep, I think that’s a good suggestion. I inspected the terminations and wires, but would probably be a good idea to re-terminate them. I am kind of thinking the 2 wire (black and white) would be a good starting place. That one has the cheesiest connector.

    Tomorrow’s business. I’ve reached today’s frustration quota.☹



  • are you getting a fast red flash or a slow flash?


  • administrators

    BLTouch flashes when it is in an error state. I'm not sure exactly what causes this, but I think one of them is deploying the probe when it is too close to the bed.

    You can send command M280 Px S160 (choose the value of x and add I1 or not according to your configuration) to reset the error. Some users include this in their config.g and homing files.





  • There are 2 error states for the bltouch. a rapid flash is a mechanical issue. either the magnet is out of place when retracted or there is an issue with it moving. there is a a slower red flash that is for a wiring or connection error. either its wired wrong or it detects a random short. this is for the v2 v2.1 as far as i know.



  • Well, turns out there was a wiring/termination issue. I re-terminated the wires (black and white) and everything worked great. Thanks for all the suggestions.


Log in to reply