New edge firmware 1.18beta3

  • I've just tried updating my v0.6 board to 1.18beta3, however, when I try to load the web interface I'm given an error that the connection was refused.

    I can connect over USB and FTP without issue, and the terminal confirms that the HTTP port is enabled. I've updated the web interface to 1.15-b2 too.

    When I move back to 1.17d, everything is fine again. Any ideas?

  • administrators

    I presume this is on a Duet 06 or 085. Have you by any chance been using an HTTP port number other than 80?

  • Indeed, it is a Duet 06 and I have tried M586 with and without an R parameter. When using R, I set the port to 80.

    I have also tried enabling debugging over usb and while I see many logs when connecting over ftp using 1.18beta3, or over http when using 1.17d, I get no logs when trying connect via http using 1.18beta3.

    I can provide logs if needed?

  • administrators

    Strange, my Duet 06 is working just fine. I don't have any M586 commands in config.g.

  • Hmm, okay, I have another 3 at work using Duet 06 boards that I can easily test today.

    I hadn't realised you could omit the M586 commands. I only really added it to enable FTP support which I use occasionally so I thought I might as well add the line for http too.

  • administrators

    You don't need to use M586 commands if you only want http, because http (only) is on by default. I guess I should check that M586 P0 S1 in config.g doesn't actually turn http off!

  • So, I've just tried the same setup on my printer at work and like yours, it doesn't have any problems either with or without M586 P0 S1. I'm clearly missing something stupid on my setup at home. It's just bizarre that I have no problem if I load 1.17d, but it instantly becomes unresponsive with 1.18beta3. I shall have to keep digging.

  • I'm having a weird bug when printing in 1.18beta3. I sliced with KISS. When the printer goes to print the first line is good, but as soon as it gets to the first corner weird things start happening. I'm assuming its running into a step generation limit because it slows down a bunch and the extruder starts to fly, trying to rapidly extrude. I have no clue how to describe it, it seems to be following the correct path, but it is trying to extrude much more than it should?

    I'm trying a print out on an older file, and after this I will try reloading the firmware and then try switching to relative extrusion in KISS.

    EDIT: All was caused by KISS not including absolute and relative M codes.

  • Hello,
    Possible bug in 1.18beta3.
    After a print is finished User-Defined Macros list is empty in Machine Control tab. I go to Macros tab and run a macros, then they all appear in Machine Control tab.

  • administrators

    I think this is a general issue with DWC. After I connect, the list of macros on the Control tab is usually empty. If I switch to the Macros page and back, it appears. I don't need to run a macro to make the list appear.

  • On the contrary, I usually see the list after connection… Anyways, that's not a big deal.

  • Yeah, I have a similar problem. If I already had the page loaded from a previous connect and I'm not on the Machine Control tab, none of the macros show up. I haven't tried running one to get them to show up, normally I just dc and reconnect on the machine control page.

Log in to reply