NTC3850 for Bed



  • Hi wish configure my heated bed https://www.aliexpress.com/item/Funssor-400mm-12V-24v-250W-300W-Round-Polyimide-film-Heater-bed-NTC3950-Thermistor-for-DIY-Delta/32860129407.html?spm=a2g0s.9042311.0.0.2a7e4c4dEK9xG3 on my Duet WiFi but in my config file I thing there is something wrong because the web control say a temperature of 2000 degre, I have a PT100 on extruder 1 that is wired on bed output.

    Someone can help me, because for me is not clear how to assign heaters and extruder.

    This is my configurator file:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Mon Mar 25 2019 12:03:15 GMT+0100 (CET)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M665 R283.5 L520 B200 H580 X0.0 Y0.0 Z0.0 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0.0 Y0.0 Z0.0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 P"Delta" ; Set machine name
    M551 P"samufree" ; Set password
    M552 S1 ; Enable network
    M587 S"XXXXXXX" P"XXXXXXXXXX" I192.168.1.230 J192.168.1.254 K255.255.255.0 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X32 Y32 Z32 I1 ; Configure microstepping without interpolation
    M350 E32 I1 ; Configure microstepping with interpolation
    M92 X400.00 Y400.00 Z400.00 E855.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z900.00 E1200.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X2000.00 Y2000.00 Z2000.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X1200.00 Y1200.00 Z1200.00 E1000.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H30 F120 T3600 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X24.25 Y-14 Z1.101 ; Set Z probe trigger value, offset and trigger height
    M557 R190 S20 ; Define mesh grid

    ; Heaters
    M140 H2
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    ;M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P0 X200 ; Configure thermocouple for heater 1
    M143 H0 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P1 H-1
    ;M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    ;M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H0 S"EXTR" ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    M912 P0 S3 ;Calibration CPU Temperature
    M106 P2 T25:65 H100:101:102 L130 ;Cooling board

    M204 P2000 T2000
    M501

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    Many thanks!


  • administrators

    @samu_87 said in NTC3850 for Bed:

    ; Heaters
    M140 H2
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0

    That looks OK except that you have B4138 where you probably want B3950. But that doesn't explain the problem. Suggestions:

    • Send M140 from the console amd check that it reports that the bed is using heater 2
    • Send M305 P2 from the console and check it reports the correct thermistor parameters
    • Check that you have the bed thermistor connected to the E1 thermistor input (not the bed thermistor input)
    • Check with a multimeter that the thermistor isn't open circuit.


  • Hi, i made the 2 test:

    1_1560163116178_Schermata 2019-06-10 alle 12.37.25.png 0_1560163116177_Schermata 2019-06-10 alle 12.37.45.png



  • just to make sure. which connector are you using for the thermistor on the duet board?



  • @dc42 said in NTC3850 for Bed:

    M305 P2 T100000 B4138 R4700

    Ok, now I can read the temperature value, can you tell me the right parameter for the M305 command? Many thanks!


  • administrators


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.