Temperature thermistor problems



  • I have had my duet wifi for a few years. I have come up against a problem that may be an issue with the Duet wifit
    I have Duet X5 attatched to the duet wifi. I have been printing with the same configuration for quite a while without issues. Recently I have added dual bed heaters and they are powered on mains and run through solid state relay which was the same thing I had been doing with a single bed heater.
    The issue is now the thermistors on the bed heater and the tool are both reading around 30c. This is incorrect as the hot end did a temperature run away.
    I have detached everything from the duet and rebooted by turning the power off. When it reboots it sill shows the temperature of the hot end and bed to be around 30c
    I'm not sure if its a fried board. The thermistors are reading around 100Kohms at room temperature so they should be ok. I have also tried with everything unplugged from the board and connecting just thermistor to the headed bed temp input with no difference...even tried heating up that thermistor and still no change. Do you have any suggestions on how to confirm if its a board issue.
    I have the heated bed as of now to trouble shoot just on the default bed thermistor and the hot end on E2 (expansion) thermistor E2 input (expansion)

    Any help would be appreciated
    Thanks
    Pete


  • administrators

    I suggest you disconnect all thermistors from the Duet, also disconnect the DueX5 ribbon cable from the Duet. Then use a multimeter to check the resistance between the VSSA pin on one of the thermistor connectors and the GND pin on one of the endstop connectors. It should be just a few ohms. if it's high then the VSSA fuse on the Duet has blown. If the reading is OK, check the bed and hot end temperature readings again, and try connecting a thermistor. If the readings are 30C still, then unless you have severely messed up the config.g file, the ADC in the MCU isn't working.



  • I am reading around 10meg ohms where is the fuse located on the board



  • the board version is 1.0



  • Hi percar

    Maybe this helps to fix your problem:
    https://duet3d.dozuki.com/Wiki/Connector_and_spare_part_numbers#Section_VSSA_fuse

    Best,
    Markus



  • thanks a million


  • administrators

    Normally if the problem is just the VSSA fuse, the thermistors read open circuit. So there is still a chance that the ADC has failed, especially as you have a version 1.0 board which is less well protected than later boards. To check the ADC, I suggest you temporarily connect VSSA to GND with a wire, then with USB power only applied see if you can get a sensible thermistor reading.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.