Fan problems can not control them



  • Good evening,

    I have exchanged my heatsink and part cooling fans. The heatsink fan is blown on Fan1 with temperature detection. The part cooling fan is quite normal on Fan0 stomped as always.

    Both fans work with 24V and are completely identical.

    Now I have the problem either nobody or if I want to regulate the part cooling fan this only at 60% turns on and controls the other automatically with.

    Has anyone ever happened something like that? can that happen through the EMC?

    at the config file I did not change anything except the fans plugged

    • ; Fans
      M106 P0 S0 I0 F500 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
      M106 P1 S1 I0 F500 H4 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
      M106 P2 S1 I0 F500 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    • ; Tools
      M563 P0 D0 H4 S"Links" ; Define tool 0
      G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
      G10 P0 R0 S160 ; Set initial tool 0 active and standby temperatures to 160C
      M563 P1 D1 H5 S"Rechts" ; Define tool 1
      G10 P1 X0 Y-18 Z0 ; Set tool 1 axis offsets
      G10 P1 R0 S160 ; Set initial tool 1 active and standby temperatures to 160C

  • administrators

    @kevino said in Fan problems can not control them:

    Now I have the problem either nobody or if I want to regulate the part cooling fan this only at 60% turns on

    Some fans don't respond well to PWM Suggestions:

    • If the problem is that you can't turn it on with less than 60% PWM but once it is running you can reduce the PWM, increase the blip time (M106 B parameter)
    • If it stops when you reduce the PWM below 60%, try a low PWM frequency (M106 F parameter)

    and controls the other automatically with.

    Are you sure? In Duet Web Control, Fan 0 and Tool Fan are the same thing (in your configuration).



  • good Morning,

    I just checked it through again and do not get it to control the Fan0 alone. Fan1 and Fan0 are always controlled. I connected the two fans via a 4-wire PVC cable, can it hang together?

    does my config look good?

    here is a video:
    youtube

    *Edit:
    i changed to an other fan (other model) and now it works.. maybe its because those are the same fans?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.