Driver defect



  • Hello,

    Yesterday i wanted to print something, and everithing worked great for the first 12mm of my model. It looked like it stopped extruding after that. When I searched for the problem, I noticed that my extruder motor did not turn when I wanted to extrude filament. To test if the motor was faulty I changed it to drive E1 and everything worked great again. I started to print another model, but the same thing happened at around 11mm. Why do the drives die mid print? I can't see anything burned or blown on the board.



  • Did you get any error messages? One of the most common reasons for extrusion to stop is if you get a heater fault.



  • No error messages. All heaters worked normally.



  • Does it happen with every thing you print or is it just one particular file?


  • administrators

    Perhaps the stepper motor cable is faulty, for instance with a bad crimp connection? Does the position of the extruder motor change with the printing height? If so then it may be that at around 11mm height, the cable is being pulled in such a direction that causes the connection to be lost.

    The TMC2660 drivers are quite reliable - I tried to blow a couple earlier this week by repeatedly connecting and disconnecting stepper motors while they were being driven, without success. When they do fail, there is usually a tell-tale burn mark on the top of the chip.



  • I tried it with two different files with the same result.
    No it's a D-Bot CoreXY with bowden extruder. Connections are all good.


  • administrators

    Here are a couple of other possibilities:

    1. If you are running the extruder at an unusually high current AND the Duet WiFi is poorly ventilated, then the drivers could be overheating after a while. You can check whether they are overheating by sending M122 and looking at the driver status section.

    2. If your power supply is overheating and the output voltage is dropping, then the extruder temperature will eventually drop enough to give a heating fault. A bad heater connection or heater cartridge could cause the same problem.

    HTH



  • Can you start another print now or are you in the situation where it won't extrude at all?



  • 1. Motors are only running at 1A and my board has a small fan for cooling.

    2. i got a 24V 40A power supply with a mains powered bed, so that shouldn't be the issue either.

    It does not extrude at all at the moment. With motors off i can freely rotate my extruder and push filament through. If i tell it to extrude it locks the motor in place and I'm not able to turn it anymore.



  • So no errors, your power supply and wiring seems fine. You can extrude by hand which rules out any possibility of a blockage in the filament path. The steppers lock the extruder which indicates that the holding current is being applied as normal. This has me stumped so I'll have to leave it for DC42 who is far more knowledgable of these things than I am. The only thing I could suggest is that the motor itself is faulty? Did you try sending M122 as David suggested?



  • M122 returns:
    M122
    Diagnostics
    Used output buffers: 2 of 32 (7 max)
    Platform Diagnostics:
    Memory usage:
    Program static ram used: 13132
    Dynamic ram used: 82180
    Recycled dynamic ram: 2992
    Current stack ram used: 2768
    Maximum stack ram used: 3752
    Never used ram: 29016
    Last reset 01:04:26 ago, cause: software
    Error status: 0
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 19.6, current 23.3, max 27.1
    Supply voltage: min 24.1, current 24.2, max 24.5, under voltage events: 0, over voltage events: 0
    Slowest main loop (seconds): 0.013700; fastest: 0.000000
    Move Diagnostics:
    MaxReps: 0, StepErrors: 0. Underruns: 0
    Heat Diagnostics:
    Bed heater = 0, chamber heater = -1
    Heater 1 is on, I-accum = 0.0
    GCodes Diagnostics:
    Move available? no
    Stack pointer: 0 of 5
    macro is idle
    http is ready with "M122"
    telnet is idle
    serial is idle
    aux is idle
    file is idle
    Network Diagnostics:
    WiFiServer is running
    SPI underruns 0, overruns 0
    Webserver Diagnostics:
    HTTP sessions: 1 of 8


  • administrators

    You need to run more recent firmware to see the stepper driver status.



  • The update of the firmware seems to have solved the issue.

    Thanks for your help



  • Definately smells like a loose connection.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.