Z Probe shows no values



  • new day new problem,

    I converted my Piezo Z probe to an inductive PNP sensor.

    Sensor

    V:10-36V
    I Signal:200mA
    PNP closer so normally open

    I have soldered the signal cable as follows:
    1.) 68K to the signal cable
    2.) then 10K to the resistor
    3) of which 2 from cable once signal and once GND.

    the wiring should be right. However, I get no signal now after I rewrite the config file. The sensor triggers on a metallic object, but the display stops at 0.

    Could it be that I've crashed the board? or does not enough volts arrive?


  • administrators

    What is the power voltage to the sensor, and what M558 command do you have in config.g ?



  • good morning,

    the power voltage is 24V and yes i used the M558 P5 command... i just checkt the signal output voltage before and after those resistors and before the resistor it says 23.6V and after those resistors it reads 21.6V 😵

    i already checkt the resistors and both show me the exact amount of 10K and 68K



  • 0_1560491663560_IMG_2617.jpg

    the upper one is my actual wiring is this one correct ? or should i use the other one?


  • administrators

    Both diagrams are wrong. Use:

    68K between probe output and Z-probe connector IN pin
    10K between Z-probe connector IN and GND pins



  • ive managed this but the probe does sometime not trigger while running g32 oder g29. While calibrating everything just works fine.

    the other thing is, the lights on the z-probe will light as soon as they reach the altitude, but the DWC still has a value of 0.

    I have also tested whether there are possibly places he does not recognize by I let you nozzle with a millimeter distance to the bed over the whole bed drive. A value of 1000 has been displayed at each location.

    he only sometimes makes me a leadscrew correction what could that be?

    config:
    ; Endstops
    Endstops
    M574 X1 Y1 S3 ; Set endstop controlled by stall
    M574 Z1 S2 ; Set endstops controlled by probe

    ; Zprobe
    M558 P5 H10 A3 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P100 X0 Y0 Z1.56 ; Set Z probe trigger value, offset and trigger height
    M557 X15:450 Y50:450 S100 ; Define mesh grid

    Bed:
    ; Auto calibration routine
    ;Clear and Home Printer Set Temperature
    M561 ; Clear any bed transform, otherwise homing may be at the wrong height
    M190 S60 ; Set Heatbed temperatur 60 and wait
    M109 T0 S200 ; Set Extruder0 Temperature 230 and wait
    ;M109 T1 S230 ; Set Extruder1 Temperature 230 and wait
    G1 E-5 ; Retraction Extruder -5mm
    ;G28 Y ; home the printer Y
    ;G28 X ; home the printer X
    ;G28 Z ; home the printer Z
    ;slow down movement to delineate bed touch from travel moves

    ;Probing Points
    G30 P0 X80 Y50 Z-99999
    G30 P1 X80 Y150 Z-99999
    G30 P2 X80 Y250 Z-99999
    G30 P3 X80 Y350 Z-99999
    G30 P4 X80 Y450 Z-99999
    G30 P5 X400 Y450 Z-99999
    G30 P6 X400 Y350 Z-99999
    G30 P7 X400 Y250 Z-99999
    G30 P8 X400 Y150 Z-99999
    G30 P9 X400 Y50 Z-99999
    G30 P10 X240 Y50 Z-99999
    G30 P11 X240 Y150 Z-99999
    G30 P12 X240 Y250 Z-99999 S3
    ;G30 P13 X240 Y350 Z-99999
    ;G30 P14 X240 Y450 Z-99999
    ;G30 P15 X250 Y250 Z-99999 S3

    ;M557 X15:485 Y15:485 S50 ;define levelling grid
    ;G29 S0 ;load grid levelling mesh
    G1 X250 Y250 Z20 F3000 ; get the head out of the way of the bed

    ;M500 ;save calibration to config_override.g


  • administrators

    Please check the signal voltage between the IN pin of the ZPROBE connector and ground with your multimeter. It should be very low (probably about 0.3V) when the sensor is not triggered, and about 3V when the sensor is triggered.



  • yeah i alerady checked this to be sure its wired correctly..

    i also checked it right now. not triggered its about 0.28V and triggered its about 2.98V this should be good i think.

    its also curious when iam calibrating the sensor everything works fine and also the measurement is pretty accurate ( 0.05mm deviation in 10 mesaurments). but when i hit run G32, home Z or even G29 the the duet will only take every third spot.

    maybe i need to adjust the ofset between the nozzle and the probe?

    *edit: (18:50)
    after lowering the z probe nothing changed. tried to home z and there is 0 Value. same spot same dive heights same spped while using g30 S-1 1000 Value and bed stops

    the z probe shows me a value of 0 but the console tell me that the z probe was triggered and give me an mesaurement..

    **edit: (19:54)
    i run an g32 and an g29 and here is my height map.. what could this be? i think this looks good to me and i also get no error like probe was not triggering
    maybe the sensor works? i dont know
    0_1560880560933_height map.JPG


  • administrators

    @kevino said in Z Probe shows no values:

    the z probe shows me a value of 0 but the console tell me that the z probe was triggered and give me an mesaurement..

    When you do what, exactly? The firmware may raise the print head again so quickly when the probe triggers that you never see the 1000 value in DWC.



  • when i run g32 or g29 or like when iam runing my macro of g1 z10 and G30 s-1 20 times...

    mmh really suspicious.. using duetwebcontrol 2 there was no leadscrew correction but with using the old one there is one.. mh so for me it works i think iam also doing a print and the first layer looks okay.

    maybe its because of the fast raising i dont know 😄 with the precision piezo i never had something like that.. I saw all the time those Values
    0_1560881768016_IMG_2644.jpg


Log in to reply