IDEX Duplication issues U prints, X Doesnt



  • Hello,

    I have a custom IDEX machine that's been working great for a month or so now, and I finally calibrated the 2 hot ends so I can print duplicate objects with each extruder. I went through the guide on the Duet page for configuring multiple independent extruders, and have the config setup so that Tool 2 is the duplication setup.

    I am using Simplify3D and I chopped the X width of the build area in half so that S3D works in the "box" each extruder has access to.

    I've set it up so that the printing happens with "Tool 2" "Extruder 1" in S3D, and the heaters are for T2. That all seems to work kosher. When I start printing, the U Axis moves, and starts printing as expected in its half of the build area. The X axis side just stays parked off to the side, extruding filament as if it was printing but nothing is being sent to it for movements.

    Below is the Config.g (Everything under the network section in my file) Any help would be appreciated:

    ; Movement section
    M569 P0 S0; Drive 0 goes backwards(change to S0 to reverse it) -X
    M569 P1 S1 ; Drive 1 goes forwards Z
    M569 P2 S1 ; Drive 2 goes forwards Z
    M569 P3 S0 ; Drive 3 goes backwards E0
    M569 P4 S1 ; Drive 4 goes forwards E1
    M569 P5 S1 ; Drive 5 goes forwards U
    M569 P6 S1 ; Drive 6 goes backwards Y
    M569 P7 S0 ; Drive 7 goes forwards Y
    M569 P8 S1 ; Drive 8 goes forwards
    M569 P9 S1 ; Drive 9 goes forwards

    ; Motor Assignments
    M584 X0 Y6:7 Z1:2 U5 E3:4 ; U Axis for second X stepper, dual X and Dual Y and dualZ

    ; Endstops
    M574 X1 Y2 U2 Z2 S1 ; Set endstop configuration (X and Y endstops at low end, U endstop at high end, active high, Z Max Endstop )
    M574 Z1 S2 ; Set endstops controlled by probe

    ; Motor Speeds and steps

    ; FEEDRATE CONVERSIONS
    ; 20mm/s = F1200
    ; 70mm/s = F4200
    ; 120mm/s = F7200

    M350 Z16 I1;
    M350 X16 Y16 U16 I1; Configure microstepping with interpolation
    M350 E16:16 I1; Interpolation enabled for Extruders
    M906 X1100 Y1300 U1100 Z1100 E1000 I25; Set motor currents (mA) and motor idle factor in percent
    M84 S120 ; Set idle timeout

    M92 X202.83 Y203.25 U202.83 Z1600; Set axis steps/mm
    M92 E821:821 ; Set extruder steps per mm
    ; Speeds:

    M201 X1500 Y1500 U1500 Z500 E1500; Accelerations (mm/s^2)
    M203 X12000 Y10000 U12000 Z1500 E4200; Maximum speeds (mm/min)
    M205 X25 Y20 U25 Z10 E22 ; Maximum jerk speeds mm/sec
    ;M566 X1200 Y1200 U1200 Z100 E1200 ; Maximum jerk speeds mm/minute
    ;M204 P800 T2000 ; Set printing and travel accelerations

    ; Build volume
    ;Printable volume 302x 302y
    M208 X305 Y327 U350.5 Z300 ; Set axis maxima (adjust to suit your machine)
    M208 X-46 Y-37 U0 Z0 S1 ; Set axis minimum (adjust to make X=0 and Y=0 the edge of the bed) -3mm between the X and U wit the U being 3mm further back, so add -3 to the Y number
    ;Made a change to test alignment Z-49.5 to -46 to get it centered along with the U

    ;Filament settings
    M404 N1.75 D0.4 ; Set nominal filament diameter to 1.75 and nozzle width to 0.4

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 X0 Y0 Z1 H5 F100 T4000 A10 R0.5 S0.004 ; P9 for BLTouch, dive height 5mm, probe at 100mm/s, travel 4000mm/s, up to 10 probes, pause 0.5s, variance of .004
    G31 P500 X16.5 Y27.5 Z1.03 ; Set Z probe trigger value, offset and trigger height
    M557 X5:300 Y5:300 S40 ; Define mesh grid
    M376 H2 ; Taper off compensation over 2mm of height

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 135C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 300C
    M305 P2 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 300C

    ; Virtual heater names
    M305 P101 S"DuetDriversTemp"
    M305 P102 S"DuexDriversTemp"

    ; Fans
    M106 P0 C"E0 Part Fan" ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 H-1 S0 C"E1 Part Fan" ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    ; Default Part Fans to 0
    M106 P2 F1 L100 X255 B1 T40:50 H100:101:102 C"Board Fans" ; Set fan 2 Duet case fan. Turns on when the MCU temperature (virtual heater 100)
    ; reaches 40C and reaches full speed when the MCU temperature reaches 50C or if any TMC2660
    ; drivers (virtual heaters 101 and 102) report that they are over-temperature
    ; Minimum speed 100%, PWM frequency 2

    ; LEDs
    ;Populate start state for LEDs
    ;start up state for the LEDs
    M106 P3 S10 C"E0 B LED"
    M106 P4 S0 C"E0 R LED"
    M106 P5 S10 C"E1 B LED"
    M106 P6 S0 C"E1 R LED"
    M106 P7 S10 C"Bed B LED"
    M106 P8 S0 C"Bed R LED"

    ; Tool 0 X - Left hand Extruder
    M563 P0 D0 H1 F0 X0 S"Left Titan Aero" ; tool 0 uses extruder 0 and heater 1 and maps X to X, use fan 2 as the print cooling fan
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    ;G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ;Tool 1 U - Right hand Extruder
    M563 P1 D1 H2 X3 F1 S"Right Titan Aero" ; tool 1 uses extruder 1 and heater 2 and maps X to U, use fan 1 as the print cooling fan
    G10 P1 X0 Y-2.95 Z0 ; Set initial tool 1 active and standby temperatures to 0C (was -.71 before adjusted the Left X axis down)
    ;G10 P1 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Duplication Tool 2
    M563 P2 D0:1 H1:2 X0:3 F0:1 S"Dual Duplication Print" ; tool 2 uses both extruders and hot end heaters, maps X to both X and U, and uses both print cooling fans
    G10 P2 X150 Y0 U-150 S0 R0 ; set tool offsets and temperatures for tool 2
    M567 P2 E1:1 ; set mix ratio 100% on both extruders
    ;M568 P2 S1 ; turn on mixing for tool 2 (Deprecated)


  • administrators

    I would find it easier to understand your configuration if you centred the print area at X=0 Y=0 (which would also support mirror mode). But from your M208 commands, I guess that for single-extruder printing you have centred it on X=150 Y=150.

    I don't know how you have centred your print in the slicer when you are slicing for duplication mode (if you were centering on X=0 Y=0 for single extrusion mode then it wouldn't change), so I don't know exactly what is going wrong. But I can see that you have defined your X and U tool heads to be 300mm apart, because you have given them offsets of 150mm and -150mm in the G10 P2 command. This is wrong, if the bed is 300mm wide then they should be 150mm apart. So try changing the offsets to 75mm and -75mm.



  • Yep, that was the issue DC42, I started to figure that was the problem when I was thinking of the alignment I have on this printer - Justified to the left side so I had to set the offset to 0 on the X Axis hot end. Now it prints great!

    Thanks,
    Joe


Log in to reply