7.5 Fuse keeps blowing with nothing connected.



  • Hello everyone. Got some problems.
    Am using a Duet Wifi 1.04 on my custom built 3Dprinter. It worked fine yesterday and printed well. Today when I turned the power on, preheated the bed and hotend everything went smooth, it homed befor the printe and then, got me grounding error on the steppers.
    Tried resetting a couple of times, made an inspection and found that the 7.5 fuse for the heater and steppers was blown.. Changed it, plugged everything out from the board except power, turned the power on and poof.. ther it goes again..
    I know the green power cable connector on the board was a bit loose, so i soldered it a bit but no luck.
    Without the fuse and power on I get no VIN reading on the webconsole except the usb power.
    I find no bent connectors or blown chips..

    Any idea what to check for?


  • administrators

    Does any of the stepper driver chips look damaged?



  • No, all look intakt. I checkt that the pcb cables have power, mesured the fusecontacts without fuses inserted and god following results shown in picture below.

    alt text

    Feels wierd that the 7.5A fuse blows but that the 1A fuse shows 0V?


  • administrators

    Does the small square chip U3 look intact?



  • yes nothing visible on either front or back side of the chip.


  • administrators

    @princessalbert, I am sorry that your Duet seems to have failed. I assume that you haven't mounted it so close to a conductive surface that some pins on the back of the Duet are contacting that surface. If it's a genuine Duet within the 6 month warranty period, ask your supplier to replace it.


Log in to reply