Internal 5v problem



  • I have a Duet 2 WiFi I bought through Filastruder that I've been having some trouble with.

    When I first got the board, I couldn't access the web control. It turned out that the board refused to access or initialize the SD card. The problem persisted through multiple cards, formats, and file sets. I'd get extremely slow access speeds of 0.2MBS on system diagnostics if there were files on the card. Empty cards would show as 20MBS. Reinitialization commands would return errors.

    I sent the board back. They tested and couldn’t find anything wrong. They sent it out with a new SD card and it initially worked. I accessed web control fine. I updated parameters. And then I plugged it into my existing Anet A8 machine. The A8 worked fine on the original control board. I plugged everything into the Duet save for the hot end since I was missing a screwdriver. I got back into web control and swapped back to Z stop instead of BLTouch since the mount I had printed didn't fit. The update went through fine, no trouble at all.

    The next day however, I couldn't access web control again. I noticed that the 5v light was off. So I immediately disconnected the power supply and started checking the wiring. No issues found. I go to plug into USB, and I immediately get a pop, all the status lights flash on once and then go dead. I get a USB current overload warning on my laptop. After that, I can get the 5v and diagnostic lights to light briefly on USB power and they quickly fade off. I tried plugging into a powered hub, and noticed a slight buzz and the USB cable getting hot before I shut everything down.

    No fuses are blown There don't seem to be any problems when on 12v power save the 5v rail doesn't work. And on USB 5v power, I get a current overload like something is shorted. All wiring has been triple checked with no issues, no shorts. And nothing was wired directly to 5v. Only 12v motors and 3.3v sensors. Without having any access to testing equipment, my best guess is a problem in the internal 5v regulator. What else should I be looking at? Filastruder old me that because everything worked when they tested, they'd need an admin from these boards to say it was likely bad hardware for them to swap it out.


  • administrators

    @Moncapitaine, I'm sorry you've had a bad experience with two boards that board. I agree, it's likely bad hardware, possible a U3 failure. Filastruder, please swap it out.



  • @dc42 said in Internal 5v problem:

    @Moncapitaine, I'm sorry you've had a bad experience with two boards. I agree, it's likely bad hardware, possible a U3 failure. Filastruder, please swap it out.

    He has not had a problem with two boards, he said filastruder checked it, couldnt find anything wrong and returned it with a new sd card. So its the same board with a recurring issue.



  • Thanks for the help gentlemen. It's appreciated.


Log in to reply