new tool isn't working...



  • Hey there,
    tried to a assign a new tool but it seems it doesn't work. I can select it from the Tools but it looks funny - asking to select/deselect and load filament. I already made tool 0 which is working fine and doesn't have those type of options.

    thoughts?

    here's my config:

    ****; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu May 02 2019 17:36:54 GMT+0300 (Israel Daylight Time)

    ; General preferences
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M568 ; tool mix ratios on

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X400 Y400 Z400 S0 ; Set axis maxima

    ; Network
    M550 ; Set machine name
    M552 S1 ; Enable network
    M587 ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive X goes backwards
    M569 P1 S0 ; Drive Y goes backwards
    M569 P2 S1 ; Drive Z1 goes forwards
    M569 P3 S0 ; Drive E0 goes backwards FEEDER
    M569 P4 S1 ; Drive Z2 (E1) forwards
    M569 P5 S0 ; Drive PRINT-HEAD 8cm (E2)
    M569 P6 S0 ; Drive PRINT-HEAD 3cm (E3)
    M584 X0 Y1 Z2:4 E3:5:6 P4 ; Use E1 for Z axis

    M350 X32 Y32 Z16:16 E16 I1 ; Configure microstepping with interpolation
    M92 X157.63 Y158.96 Z400:400 E35:200:200 ; Set steps per mm
    M566 X1200 Y1200 Z24:24 E800 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z600:600 E30000 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z100:100 E20000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800:800 E800:1500:1500 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X400 Y400 Z290 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    ; M557 X15:0 Y15:195 S20 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M307 H1 B0 S1.00 ; Disable bang-bang mode for the Hotend heater and set PWM limit
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M307 H0 A107.3 C652.0 D0.6 S1.00 ; Bed PID
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M307 H1 A89.3 C110.6 D1.4 S1.00 V11.9 B0 ; Hotend PID
    M143 H1 S250 ; Set temperature limit for heater 1 to 120C
    M302 P1 S0 ; Allow cold extrusion minimum of 0

    ; Fans
    M106 P0 S1 I0 F500 H T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P3 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 H1 D0:1 ; Define tool 0
    M563 P1 D2 ; Define tool 1
    M567 P0 E10:1 ; MIXING RATIO
    G10 P0 X0 Y-35 ; Set tool 0 axis offsets
    G10 P1 X0 Y-35 ; Set tool 1 axis offsets
    ; G10 P0 R0 S200 ; Set initial tool 0 active and standby temperatures to 30C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured****



  • @cj-bravo Well you haven't assigned a heater to the tool so that might be the problem. But can you be a bit more specific rather than " I can select it from the Tools but it looks funny".

    Can you also tell us a bit more about your printer because the configuration is strange. You seem to have 3 extruders drives is that correct? But for tool zero you have a mixing ratio of 10:1 which would indicate that the extruders are running in a "push pull" arrangement and that one extruder is running 10 times slower than the other. Is that also correct? I'm guessing it might be because you have some very odd looking steps per mm settings. You are also allowing cold extrudes so is this something other than a FDM printer?

    We could really do with a bit more information.



  • 0_1561529898068_eae26706-a7cc-4896-93aa-b713b2d45a07-image.png

    Its a modified cr10 -> 3d ceramic printer.

    mixing ratio is for feeder and print-head.

    feeder is on drive 0
    print-head (8cm) is for drive 1
    print-head (3cm) is for drive 2

    tool 0 which is feeder and print-head 8cm works fine.
    drive 1 and 2 are on the DUEX5.

    not applying a heater to the tool worked well on a previous attempt try I had.

    When selecting tool 3cm the windows pops. tool 8cm doesn't do that.

    After selecting tool 3cm the extruder/retract are clickable but the stepper does nothing.



  • @cj-bravo I'm still a little confused about the physical layout of your machine and what each tool is supposed to do what but I have two ideas that might help.

    Firstly, near the top of your config.g file you have "M568 ; tool mix ratios on"
    But you haven't specified a tool so that command would probably apply to all tools and as you haven't defined a mixing ratio for the tool 1, that could be the problem. The solution is easy because that M568 command is deprecated from firmware 1.19 onwards so if you are using a version later than 1.19, you can simply omit it. Alternatively, if you are using an earlier firmware, you could use M568 P0 which would turn on mixing only for tool 0 but not for tool 1.

    I think that will cure your problem but if not you could define both tools as mixing but set the ratio for tool1 to only use one extruder drive. So.....

    M563 P0 H1 D0:1 ; Define tool 0
    M563 P1 D0:1:D2 ; Define tool 1 ; add the other two drives to this tool
    M567 P0 E10:1 ; MIXING RATIO
    M567 P0 E0:0:1; mixing for tool 1 to only use drive 2.

    I think my first suggestion should work but let us know.



  • ok. so not sure what happened but it seems to work fine right now.

    Its the same config as I did before...

    It seems that the drop down menu of the tool disappears when the tool a mixed-ratio tool.

    thanks for the trouble.


Log in to reply