Remapping Z axis - troubleshooting



  • I have a duet wifi 2 that I've been using for a few months now and the prints have been fantastic. Everything had been dialed in tight and right up until about a month ago. I'd like to remap my Z axis to the spare extruder driver. When I set the Z axis to E1 in RRF I can control the axis and everything works, except I my extruder (E0) no longer works. How do I fix this?


  • administrators

    Check that you have this M584 command in config,g:

    M584 X0 Y1 Z4 E3

    and that any M350 and M906 commands are later in config.g then that M584 command.



  • I checked the config.g file and it does show M584 X0 Y1 Z4 E3; apply custom drive mapping
    The next line is the M350 and a few lines down is the M906. What else can I check?



  • Here's a dump of config.g file

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Mon Jun 24 2019 19:38:23 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"My Printer" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Physical drive 0 goes backwards
    M569 P1 S1 ; Physical drive 1 goes forwards
    M569 P4 S0 ; Physical drive 4 goes backwards
    M569 P3 S1 ; Physical drive 3 goes forwards
    M584 X0 Y1 Z4 E3 ; Apply custom drive mapping
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z2560.00 E407.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-33 Y-12 Z0 S1 ; Set axis minima
    M208 X230 Y210 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X-18:195 Y3:195 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured


  • administrators

    @jthunderloc said in Remapping Z axis - troubleshooting:

    ; Tools
    M563 P0 H1 ; Define tool 0

    Your tool 0 is defined as not using any extruders.



  • Ah, ok. What should I set it to? 3?


  • administrators

    Add D0 to that M563 command to have tool 0 use extruder drive 0.


Log in to reply