WiFi module suddenly not connecting



  • Hardware DUet2Wifi v1.03
    Firmware: 2.03RC5
    WiFI Firmware: 1.23

    My Duet worked fine for quite some time now, I did some prints 2 days ago.
    When I tried connectng to my rinter today to print something I could not connect to DWC.

    After multiple powercycles and resets I tried connecting over USB which worked fine but my duet would not let me connect to my network.
    I tried restarting/resetting my router and deleting and adding my network again, no luck unfortunately.

    I have included the log from my terminal in this post. the only edits are private data and a bunch of repeated messages denoted with "[...]".

    Any suggestions to get my board working again?
    I just received 5 more spools of filament..🦆

    Terminal Log



  • Are you setting a static IP address for the Duet in the config.g?
    Or are you using DHCP and letting the router assign an IP address?
    Can you log into the router to see if the Duet is connecting?
    When you are connected to the Duet via USB you can turn the wifi module off and on again, which should have it attempt to reconnect.

    Ideally, you should be using DHCP to let the router assign an address, and then have the router reserve that address for the Duet.


Log in to reply