Duet2 Ethernet: M552 S1 ok Response

  • Hey everybody,

    So I recently just purchased the Duet3D with Ooznest CNC and have had immense trouble configuring the Duet Web Control. I have followed the guide to connect via ethernet but have not had any luck actually connecting. I keep getting stuck at the section that says to send the command: M552 S1 and wait 30 seconds for a configured IP address for the Duet. Every time I run it I do not get a response and it just says "ok." I don't know what I am doing wrong. I have it connected directly to the Router and have my laptop connected wireless. My driver should be up to date and everytime I have tried to ping to the preconfigured IP address for this Duet is always says "request timeout." If anybody could help me that would be so amazing! I don't understand why it is so hard to actually get this thing to run!! If you need pictures of YAT or whatever it may be, just let me know!

    Thanks and all the best.

  • Don't think you get any more response than OK.

    Run just M552 (without any parameters) to review the current network setup.

  • This is what I get when I put in M552: "Network is enabled, configured IP address:, actual IP address:"

    I try to ping this IP address and the command prompt window says that the "request timed out"

  • Maybe if you describe your network setup a bit more, switches, routers, ip ranges it would help to find out where it goes wrong

  • @nicky-t You do have the DWC files in /www on the sd card?

  • @stephen6309 said in Duet2 Ethernet: M552 S1 ok Response:

    @nicky-t You do have the DWC files in /www on the sd card?

    shouldn't affect the ability to ping the duet, that would result in a http 404 error when trying to open the dwc, which can't happen if the computer and duet cant even ping each other.

  • We have a router and modem. I am not sure what you mean by network set up. There is no password for the network if that is what you mean. All I have been doing is following the setup guide from the link on the card that came with the device. Before that, we tried using other software to connect it as well and it did not work. I installed the driver on the computer from reprap and it is all on windows 10. Would a screen image of YAT help?

  • Maybe show us the output of route printfrom the computer you're trying to ping the Duet from?

    No need for an image of YAT as long as M552 shows network is enabled and it has an IP address. Then we just need to find out why you can't reach said IP.

  • 1_1562857302375_routeprint2.PNG 0_1562857302374_routeprint1.PNG

  • This is what I get from route print. the pictures are reversed.

  • The Duet is reporting an address of 192.168.1.x

    Your computer is reporting an address of 192.168.0.x

    Try setting one or the other to the same block of IP addresses.

    Either change the Duet to an 192.168.0.x address or the network to 192.168.1.x address.

    The easiest would be to change the Duet address to communicate with your existing network.

  • The duet is probably getting its IP address from DHCP unless told otherwise? Which would lead me to believe the computer is connected to the modem, and the duet to the router, and that can prevent the two from communicating (on the assumption the the router is doing some NAT stuff, or not configured correctly).

    Please describe more how these things are connected to help us determine where the problem is, also show us your config.g file to see if you are setting a static IP address or using DHCP for the duet.

  • It looks to me like the pre-configured IP address is wrong as it isn't the same network as the PC. Looks like is what is intended.

  • is the IP address configured in a Maestro fresh from the factory.

    If you want to enable DHCP on a Maestro board, you need to use M552 S1 P0.0.0.0

Log in to reply