Display of axis

  • @deckingman ,@bearer , I still are reading and reading, my self in to this config.g file.
    i do not have yet a config other than the basic one. (and experimenting from that point)

    @bearer said in Display of axis:

    they should be displayed if they are configured i think.

    Jea, now you speak about so, i have read somewhere about this, can't remember where..

    @deckingman thank you for the lead, i will make use of your info, and pointing me to the M584 code and the P values

  • As i played with this M-code, and no change appeared, can it be so that the board actually has to be hooked up to the machine to show the status of the machine??

  • @thomss said in Display of axis:

    As i played with this M-code, and no change appeared, can it be so that the board actually has to be hooked up to the machine to show the status of the machine??

    Hooked up to steppers and endstops: NO

    Communication between Duet Web and a powered up, configured, running, Duet board: YES. DWC pulls status configuration and "self configures".

    Please post the results of entering this in a browser:

    Enter in a browser, using the IP address of your printer. My result is below, some key things bolded. There are lots of other pieces of information in this status, look at yours thoroughly. This, plus RR_CONFIG, is what DWC uses to self configure.

    {"status":"I","coords":{"axesHomed":[1,1,1],"wpl":1,"xyz":[0.000,0.000,621.767],"machine":[0.000,0.000,621.767],"extr":[0.0]},"speeds":{"requested":0.0,"top":0.0},"currentTool":0,"params":{"atxPower":0,"fanPercent":[0,100,0,0,0,0,0,0,0],"fanNames":["","","","","","","","",""],"speedFactor":100.0,"extrFactors":[100.0],"babystep":0.000},"seq":1,"sensors":{"probeValue":0,"fanRPM":0},"temps":{"bed":{"current":21.3,"active":0.0,"standby":0.0,"state":0,"heater":0},"current":[21.3,20.5,2000.0,2000.0,2000.0,2000.0,2000.0,2000.0],"state":[0,2,0,0,0,0,0,0],"names":["","","","","","","",""],"tools":{"active":[[0.0]],"standby":[[0.0]]},"extra":[{"name":"MCU","temp":34.0}]},"time":9814.0,"coldExtrudeTemp":160.0,"coldRetractTemp":90.0,"compensation":"None","controllableFans":4,"tempLimit":290.0,"endstops":4088,"firmwareName":"RepRapFirmware for Duet 2 WiFi/Ethernet","geometry":"delta","axes":3,"totalAxes":3,"axisNames":"XYZ","volumes":2,"mountedVolumes":1,"name":"Danal's BFD","probe":{"threshold":100,"height":-0.10,"type":5},"tools":[{"number":0,"heaters":[1],"drives":[0],"axisMap":[[0],[1]],"fans":4,"filament":"","offsets":[0.00,0.00,0.00]}],"mcutemp":{"min":33.1,"cur":34.0,"max":34.5},"vin":{"min":24.8,"cur":25.0,"max":25.3}}

  • @danal took a wile before i understood,
    My board, laying next to me, is only hooked up tu 5 volt (usb) and not jet to the machine,

    so as requested...

    {"status":"O","coords":{"axesHomed":[0,0,0],"wpl":1,"xyz":[0.000,0.000,0.000],"machine":[0.000,0.000,0.000],"extr":[]},"speeds":{"requested":0.0,"top":0.0},"currentTool":-1,"params":{"atxPower":0,"fanPercent":[30,100,100,0,0,0,0,0,0],"fanNames":["","","","","","","","",""],"speedFactor":100.0,"extrFactors":[],"babystep":0.000},"seq":13,"sensors":{"probeValue":1000,"fanRPM":0},"temps":{"current":[2000.0,2000.0,2000.0,2000.0,2000.0,2000.0,2000.0,2000.0],"state":[0,3,0,0,0,0,0,0],"names":["","","","","","","",""],"tools":{"active":[],"standby":[]},"extra":[{"name":"*MCU","temp":40.0}]},"time":90031.0,"coldExtrudeTemp":160.0,"coldRetractTemp":90.0,"compensation":"None","controllableFans":1,"tempLimit":290.0,"endstops":4095,"firmwareName":"RepRapFirmware for Duet 2 WiFi/Ethernet","geometry":"cartesian","axes":3,"totalAxes":4,"axisNames":"XYZU","volumes":2,"mountedVolumes":1,"name":"WorkBee","probe":{"threshold":600,"height":39.55,"type":5},"tools":[],"mcutemp":{"min":28.9,"cur":40.0,"max":41.0},"vin":{"min":0.7,"cur":1.7,"max":1.8}}

  • @thomss This would be so much easier if you would post the config.g file that you are using. It looks like you have 4 axes defined but only 3 being displayed because as I said before, you are most likely don't have a "P" parameter in M584 or you have it set to P3. But unless you tell us how you have it configured by posting the config.g file, it's impossible to say.

  • @deckingman As i said before, i only have the basic config.g file.


    i have tried to give the P a value of 5, but did not see really a change.

    wat do i have: (board and machine are not hookt up yet)
    X-axsis, Y-axis master and Y-axis slave Z-axis A and B axis (rotation head on the Z-axis)

    Those last two i will be removed and not use on this machine for now.

    the machine is screw-driven and i do use a stepper expansion board because the Duet 2 is not capable to run steppers over 2A, and i use external steppers.

  • As in the file:

    M584 X0 Y1:3 Z2 U9 E4:5:6 P5

    where X= #0 stepper
    where Y= #1 & #3 stepper
    where Z= #2 stepper

    Where U = dummy #9
    where 4,5 and 6 are E-motors

    i did just now:
    M584 X5 Ym6 Ys7 Z8 U9 P5
    where motor 5-9 are on the expansion breakout board.
    As you see, i used Ym and Ys (master and slave), and P5 to make 5 motors visible.
    than i did :
    M584 X5 Y6:7 Z8 U9 P5
    but non is happening...

  • If I enter the M584 command in the config.g you posted, my Web interface changes to show a U axis within about 1/2 second. You can see the exact command at the top of the screenshot.

    I also get a message indicating that P5 is invalid:



  • If I enter the M584 with P4 instead, U displays properly, and there is no error.

    If this is not working for you... perhaps your combination of DWC release and firmware release is not valid. I am running:

    Duet Web Control 2.0.0-RC2 / RepRapFirmware 2.03RC3 

  • If this is indeed a CNC machine I don't quite see why you would configure E and use P in M584. Just map X,Y,Z,A and B, no P parameter and all axis should be visible. P is used to limit the number of axis shown, not to enable them.

  • Yess, Yess... This is the missing brick, On this i can continiu-

Log in to reply