Duet 2 Wifi Doesn't Boot or Show Up as USB Device

  • I've had my Duet 2 WiFi for a little while now. Today, when I went to turn it on, it wouldn't boot. The wifi light wouldn't turn on and I couldn't connect over wifi. I then disconnected it from main power and connected it to my computer over USB. It wouldn't show up. No USB devices. I verified the 3.3v and 5v LEDs were lit and the USB LED was lit. I then tried erasing the firmware: Unplugged from computer, jumped the erase pin, plugged into computer, waited a few seconds, unplugged from computer, removed erase jumper, plugged back in. Now the SD Card light turns on as well but it still doesn't show up on my computer. It's connected directly to a USB port on the computer (no hub in-between). Restarting the computer didn't help. Any suggestions would be really appreciated. Thanks.

  • Moderator

    Try a different cable, different port, and or different computer just to rule it out.

  • administrators

  • I tried a different cable, and every USB port on my computer with no success. I went through the “what to do if your duet won’t respond” guide on the website too. I didn’t have a different computer to use but it’s possible that would’ve fixed the problem. After rebooting the computer multiple times and rebooting the duet multiple times, it did eventually get a connection and I was able to reflash the firmware. Not sure why though.