Duet Web Control2.0.0 rc7 behind ssl Proxy



  • Hi,

    I have a nginx ssl Proxy to access my duet from The Internet with Duet Web Control 1.22.6 it works perfect.
    Today i Have tried the 2.0.0RC7 with the result that i can Open The webpage from The Duet with a Network error Can't connect to the Printer. The Problem is that the Webcontroll sends a http request
    (Laden von gemischten aktiven Inhalten "http://..de/rr_connect?password=reprap&time=2019-7-16T22%3A0%3A13" wurde blockiert.) This request will be blocked by the Browser because it is not a ssl connection.

    here the Same request with Web Controll 1.22.6 which works over the Proxy

    https://.*.de/rr_connect?password=reprap&time=2019-7-16T22%3A19%3A30

    regards

    Andy



  • @siam There is an open Pull Request that in theory should solve this problem. You could try that out and give feedback if it really solves the problem (since my reverse proxy is secured on another level and not using TLS I could not try it).



  • Sorry for the delay!
    I have changed the two js Files as shown on github the problem is not solved with it 😞
    The connect part is still in http



  • @siam Thanks for the feedback. I will look into it again.



  • I've been looking to get this to work for a while too. I will follow this thread with great interest 🙂



  • I've been looking at it again last week already and could not find the issue. Today I am going to change my reverse proxy to use TLS and then I can debug where the http requests originate from still.



  • OK, I changed my setup to use TLS on the reverse proxy and it works. I had to completely reload the page, though but then it worked.

    @SIam Did you compile the changes via npm run build and upload the resulting zip file?

    EDIT: I uploaded a patched version of 2.0.0-RC7 to my Dropbox.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.