E1 filament sensor detection/configure



  • I have the duet ethernet and duex5 with the mmu2 hardware. Everything is setup minus the second filament sensor. It's connected on e1 endstop connector and I've tried every combination I can think of but I can't get the e1 status to show using 591 or m119. D0 endstop shows but when I use 591 D1 nothing shows. I even tried defining axis v with the endstop but nothing is triggering even though the light on the endstop goes on and off when the probe is manually touched with metal.



  • So I changed my configuration to M591 D1 P2 C4 S1

    When I type M591 D1 in the console all I get is M591 nothing else.

    Board: Duet Ethernet 1.02 or later + DueX5
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.04RC1 (2019-07-14b1)


  • administrators

    Do you definitely have an extruder drive 1? Please post your complete config.g file.



  • ; Communication and general
    M111 S0 ; Debug off
    M550 Sir ; Machine name and Netbios name (can be anything you like)
    M551 Preprap ; Machine password (used for FTP)
    M929 ;Enable logging
    *** Ethernet networking: The following lines are used for factory testing - PLEASE REMOVE THEM

    ;*** End of factory test lines to be removed

    ;*** Networking
    M552 S1 ; Turn network on

    M555 P2 ; Set output to look like Marlin
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Disable Fan 1 thermostatic mode
    M106 P1 H-1
    M667 S0 ;selects Cartesian mode
    ; Axis and motor configuration
    M569 P0 S1 ; Drive 0 goes forwards X
    M569 P1 S1 ; Drive 1 goes forwards Z
    M569 P2 S0 ; Drive 2 goes forwards Y
    M569 P3 S0 ; Drive 3 goes forwards E
    M569 P4 S0 ; Drive 4 goes backwards V
    M569 P5 S1 ; Drive 5 goes forwards U
    M569 P6 S0 ; Drive 6 goes forwards W

    M584 X0 Y1 Z2 E3 V4 U5 W6 ; Apply custom drive mapping

    ;Endstops

    M574 X1 Y1 S1 ; set endstop configuration (all endstops at high end, active high)

    M574 Z1 S2 ; Define z to use probe. Home to min
    ;M574 V P2 S0 C4
    M574 U1 V1 W1 S3 ; Set additional axes as sensorless endstops
    M591 D1 P2 C4 S1
    M591 D0 P2 C3 S1 ;Filament sensor extruder 0, simple sensor,
    ;M574 V1 S1

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration
    M350 X16 Y16 Z16 E16 U16 V16 W16 I1 ; Set 16x microstepping with interpolation
    M92 X79.5031056 Y640 Z400 U400 V145 W26 ; Set axis steps/mm
    ;M350 X4 Y4 Z16 E16:16 I1 ;x and y 1/4 step
    ;M92 X198.75 Y160 Z400
    ;M350 X6 Y6 Z16 E16:16 I1 ;x and y 1/4 step
    ;M92 X397.5 Y320 Z400

    M906 X2000 Y2000 Z850 E1200 I60 ; Set motor currents (mA) and increase idle current to 60%
    M906 U1000 V2000 W2000 I30 ; Set motor currents (mA) and increase idle current to 30%
    M201 X2000 Y1200 Z600 E2000 U500 V2000 W2000 ; Accelerations (mm/s^2)
    M203 X9000 Y1400 Z1000 E1080 U5000 V10000 W20000 ; Maximum speeds (mm/min)
    M204 P600 T10000 ; Set printing and travel accelerations
    ;M572 D0 S0.25 ; Pressure advance
    M566 X600 Y300 Z18 E400 U400 V2000 W2000 ; Maximum instant speed changes mm/minute

    M208 U0 V-1000 W0 S1 ; Set axis minimum
    M208 X845 Y519 Z380 ; set axis maxima
    M208 U75 V1000 W78 S0 ; Set axis maximum
    ; Thermistors
    ;M305 P0 T100000 B3950 R4700 H30 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M307 H0 A-1 C-1 D-1 ; Disable temp sensor, heater 0 is now GPI0
    ;BLTouch -Heaters
    M307 H7 A-1 C-1 D-1; ;Disabel the 7th Heater to free up PWM channel 5
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    ;M305 P2 T100000 B3974 R4700 H30 L0 ; Put your own H and/or L values here to set 2nd nozzle thermistor ADC correction
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M570 S180 ; Hot end may be a little slow to heat up so allow it 180 seconds
    M140 H-1 ; Disable heated bed, this is controlled externally
    ; Adjustments for dummy heaters on test rig
    ;M307 H0 A250 C140 D5.5 B1
    ;M307 H1 A250 C140 D5.5 B0
    ;M307 H2 A250 C140 D5.5 B0

    ; Fans
    M106 P1 S1 I0 F500 H T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ; Tool definitions
    M563 P1 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;*** If you have a single-nozzle build, comment the next 2 lines
    ;M563 P1 D1 H2 ; Define tool 1
    ;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures
    M92 E137.65 ; Set extruder steps per mm

    ; Z probe and compensation definition
    ;*** If you have a switch instead of an IR probe, change P1 to P4 in the following M558 command.
    M558 P5 H5 F300 T6000 X0 Y0 Z1 ; Set Z probe type/mode 5. H=Dive Height. Fspeed the bed moves Reduced F300 to ;100
    G31 P25 X13.2 Y0 Z0 ; Set the zprobe height and threshold for Smart Effector
    M557 x64:605 Y12:509 S40 ; define grid
    ;*** If you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0 ; Axis compensation here

    M208 S1 Z -2 ; set minimum Z
    G29 S1
    T0 ; select first hot end
    ; M117 Use https://configurator.reprapfirmware.org/ to set up your printer config

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ;Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    M563 P1 D0 H1 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    M563 P2 D0 H1 ; Define tool 2
    G10 P2 X0 Y0 Z0 ; Set tool 2 axis offsets
    G10 P2 R0 S0 ; Set initial tool 2 active and standby temperatures to 0C

    M563 P3 D0 H1 ; Define tool 3
    G10 P3 X0 Y0 Z0 ; Set tool 3 axis offsets
    G10 P3 R0 S0 ; Set initial tool 3 active and standby temperatures to 0C

    M563 P4 D0 H1 ; Define tool 4
    G10 P4 X0 Y0 Z0 ; Set tool 4 axis offsets
    G10 P4 R0 S0 ; Set initial tool 4 active and standby temperatures to 0C
    ;



  • I've tried 122 as well and nothing about second filament sensor. I also just recently updated to the most recent firmware.



  • Does my config look ok? I also updated to the latest firmware I didn't see anything change on the release notes.



  • okay fine



  • So I figured something out. When M591 D0 and what ever c* pin is entered it reads back the value of what ever endstop is configured the next time M591 D0 is entered.

    Also I had the endstop connected with just a resistor and just recently changed it to a optocoupler but the pin is now reading always high. Is there a way to enable the internal resistor or remap the extruder pins on e1?


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.