Height map has a substantial Z offset error with mesh

  • Hi All,

    I recently upgraded my CR10S with a duet 2 ethernet and added the IR abl probe for bed leveling, it worked flawlessly for about a month and since yesterday my mesh is suddenly lifted 0.25 mm or higher than usual and it is messing up my first layer.

    I have tried to use z babystepping to compensate but it need to go up to like -0.8mm instead of less than -0.2mm before.
    I'm also getting the error message:

    Warning: the height map has a substantial Z offset. Suggest use Z-probe to establish Z=0 datum, then re-probe the mesh.
    30 points probed, min error 0.074, max error 0.231, mean 0.146, deviation 0.044
    Height map saved to file heightmap.csv

    Looked up what it means and I have checked that I am using G30 to home Z before G29 but still getting this problem.

    My mesh before:
    alt text

    Mesh now:
    alt text
    alt text

    I did recently upgrade the firmware to 2.03 but it did work for a few days after that and I havent made any changes to firmware since. I have now installed 2.04RC1 and still have the same issue.

  • Moderator

    Please post your config.g and homing files.

  • Moderator

    It doesn't look like there is any weirdness with your homing files.
    Do you also have a bed.g macro?
    What does your slicer start gcode look like? Does it call G32?
    When are you running G29 or loading the heightmap?

    I would suggest redefining your trigger height and re-running mesh compensation with 2.03.


  • This is my starting gcode:

    M572 D0 S0.2 ;Pressure Advance
    M82 ;absolute extrusion mode
    G90; Use logical positioning
    G92 E0 ;Nulls out the extruder
    G28; Homes the nozzle on x,y,z
    G28 Z; Homes the z axis again
    G30; Home z again with probe
    G29 S1; load last bed mesh from memory
    G4 S15; waits 15 seconds for the heaters to recover

    G1 Z5 ;moves up a bit
    G1 X295 Y30 F2700 ;moves over the front right corner.
    G1 Z0.3 F100; height of small blob
    M106 S255 ;turns fan on full
    G1 E20 F200;extrudes a small blob
    G4 P4000; Waits 4 seconds to the blob to cool a bit
    G1 Z0.5 ;moves up a bit
    G4 P5000; Waits 5 seconds to leaker to flow and cool a bit
    G1 Z7 F100; Pull out of the blob a bit
    G4 P5000 ; used for cooling down the stringing
    M106 S0 ;turns fan off
    G92 E0 ;Nulls out the extruder
    M83 ;relative extrusion mode

    I manually do the mesh with the web gui once in a while and the starting gcode just does G29 S1 to load it.

  • Moderator

    That looks ok too.

    As I said above, clear your heightmap, remeasure your trigger height, and then redo the G29 with 2.03. See if the problem persists.

  • EDIT: also i found the bed.g as well here it is:

    I did the Calibrate the Z probe trigger height in the link you provided, also deleted the heightmap file before proceding and im still getting the exact problem.

    alt text
    alt text

  • your bed and hotends have the default B4138 value.
    this is most likely incorrect for your thermistor and will report the wrong temperature.

  • @veti hmm what should I set it to? I have the stock cr10s thermistor for both hotend and bed

  • according to the marlin config

    the hotend is a epcos 100k and the bed is a semitec 104GT-2, both can be selected in the duet configurator.

  • @veti this may sound stupid but how do i select it in the duet configurator lol... is it the rrf config tool? It just asks me to type in the b value there are no preset selections.

    alt text

    I have found the Semitec b value in the wiki here but Epcos 100k have 3 different model so not sure which one I should be using...

  • click into the beta field and the selector will open

  • @veti OH now i feel dumb xD thanks for the tip there, got my bed at 4267 and nozzle at 4092 now 😄

    I looked up datasheet for both thermistor and used that instead of the preset since it seem to be incorrect as the EPCOS was only 10k ohm on the rrf.

  • you are correct. that is a mistake in the configurator. it is supposed to be 100k and 4092 B

  • Back on topic tho... I'm running a new bed mesh now with the bed heated up to 60c... I'm sure the temp will be more accurate than before now.

    but mesh has no luck, bed is still floating in midair on the mesh for some reason..

  • but it does work if you probe before every print?

  • @veti that will have same result, basically my mesh is like 0.7 mm higher than what its supposed to be, I can use the Z baby stepping in web gui to lower the nozzle to around -0.95 mm and it'll print OK. Before the lowest I have used is like -0.25 mm

  • i am guessing the you are doing the homing with the hotend and bed turned on.
    did you create the heighmap under the same conditions?

  • @veti yes everytime mesh is done it is at printing temp

  • @dc42 do you have any idea what could cause that behavior. I tried to help him find the issue but since z-homing with the mini IR works flawlessly I can't think of what it actually is.
    it seems like it just adds a certain offset value to the probe values at some point for no reason.
    as if z0 gets redefined after initial z homing.

  • Just an update.. I did absolutely no modifications beside the heater stuff yesterday, however today i just did another mesh and there was 1 point that was below 0 and the warning message went away. I started another print and my z babystepping value went from -0.95mm to -0.45mm which is much better than before but still not what I had before which is max -0.25mm.

    alt text

  • you are probing on glass with an Ir sensor.
    check that the point where you are probing does not have any special feature, since its the center and that is where the thermistor is.

    do check the repeatrability of your probe at different places.

  • Hey Veti,

    no he's not probing on glass he uses a TH3D sheet, completely opak and it worked flawlessly before. That phenomenonm started to appear all of a sudden with nothing changed. Btw it got better again, but the repeatability is still rather bad.
    Switchin the printer off and on again usually trows the settings off by about 0.3mm wich is way too much imo.

Log in to reply