Duet suddenly not reading micro sd card



  • I've been using the Duet wifi 2, now for 2 or 3 years, and it suddenly cant read the sd card. I havent been able to connect to wifi for well over a year so the sd card gets lots of use. I tried another card but it doesnt respond to it either. Are there any command i could try entering in the panel due to get an idea of the problem?



  • Actually when sending commands via panel due, there is no response, probably duet has to read the sd card before it can do anything. Wondering if there something wrong with the board.



  • Does the card still show up in a PC?
    Can you connect to the board via USB and get a M122 report?


  • administrators

    Check whether you can read the card (or another SD card not larger than 32Gb) in a PC. Then put it in the Duet and send M20 to mount it. If it fails to mount, there should be an error message. If it mounts successfully, send M39 to get the details.



  • I can read the card on a pc, and tried 4 other cards. When sending commands M20, there is no feedback at all, the message area stays blank.

    There is no reaction when trying to move the nozzle. The nozzle temp reads 0, it will allow me set the temp but there is no reaction after doing so.

    I have been trying to connect to the board on my pc, but Windows 10 no longer shows com ports, they are now usb ports. So Yat shows no com ports available. If switched to usb ports in Yat it lists all my usb ports and whats connected to them, except it doesnt show the Duet when its plugged in.

    I should mention that before it stopped working, the nozzle was at 190 deg and i was extruding some filament, then it suddenly shut down as it would with a heater fault except there was no message, it hasnt worked since.


Log in to reply