Duet Web Control stopped working after update to 1.22.6



  • I have a DuetWiFi v1.01 that I have not used in years, I updated the firmware to 2.01RC1, Duet Web Control was at v1.21 and it was working correctly however after I updated to 1.22.6 it stopped working.
    I can see the page but it never connects, I can see the attempts to connect but eventually it comes up with an error, depending on the browser I am getting different errors in chrome I get..

    "Connection Lost
    The connection between the browser and your machine has been interrupted
    Reason: Request Timeout
    Please wait while a new connection is being established...".

    In Edge I see the error

    "JavaScript Error A javaScript error has occurred so the web interface has closed the connection to your board. It is recommended to reload the web interface now. if this happens again, please contact the author and share this error message:
    Version 1.22.6
    Message: Unable to get the property 'drives' of undefined or null reference
    URL: http://192.168.1.194/js/dwc.js
    Line: 9438:3
    Error object: {}"

    I already clear cache in both browsers, rebooted the board, disabled and re-enabled WiFi, re-enter M587 S"my-network-ssid" P"my-network-password". The board is connecting to the network and I can see the page to Duet Web Control however nothing that I am doing is letting me connect to the board. I am throwing the towel and hoping for some help from the board, thank you!



  • You should not use any RC firmware.
    They aren't stable, the latest stable is 2.03 and use Duet2Firmware-2.03.zip, it contains all need files.



  • Weird thing is that it work correctly with Duet Web Control v1.21 without any issues until I upgraded to v1.22.6.
    Are you saying that that the release candidate 1 won't work well with v1.22.6? Is this a bug then? Thanks!



  • Bug is to use any release candidate 1 when they is a stable high release.
    Just don't use release candidate unless you know what are you doing.


  • administrators

    @recoil said in Duet Web Control stopped working after update to 1.22.6:

    Weird thing is that it work correctly with Duet Web Control v1.21 without any issues until I upgraded to v1.22.6.
    Are you saying that that the release candidate 1 won't work well with v1.22.6? Is this a bug then? Thanks!

    Sometimes we make a protocol change that requires both the firmware and DWC to be changed. So newer versions of DWC may require more recent firmware versions to work with.



  • Thank you for your responses gentleman, I appreciate the help. I saw the fixes for delta bots in the latest RC and I wanted to get a jump on them, it was not in my future v2.03 it is.
    Now that I lost the ability of using Duet Web Control to upload and install what would be the appropriate way to roll back to fully working firmware/DWC?
    I am looking at "Fallback procedure #1" however the instructions outline how to install .bin files not .zip furthermore I did look for "Duet2Firmware-2.03.zip" as dragonn suggested but DWC is not compressed in that file, I do see a separate "DuetWebControl-1.22.6.zip" then again it is a .zip file. Could I use .zip files as .bin? Or do they need to be decompressed to a temporary directory or something along those lines?
    Or perhaps since since DWC 1.22.6 is already installed by installing the firmaware v2.03 it will work correctly with DWC 1.22.6 without a need of re-installation of DWC? Still leaves me with the question of .zip files vs .bin. Thank you for your help!



  • DuetWebControl-1.22.6.zip needs to be extracted to the /www folder since all the DWC is a website. The files in the zip are just webpages and other code bits to make it work.

    And yes, if you put the firmware binary for 2.03 on the SD card and used the USB terminal to send the firmware update command, you should get back into step.



  • Thank you Pahaedrux, so there is no more bin for for DWC? it is all .zip and it is just a simple decompress to /www to install. In other words there is no more installing, is M997 S2 dead? there is no more use for it? Thanks.



  • https://duet3d.dozuki.com/Wiki/Gcode#Section_M997_Perform_in_application_firmware_update

    Not dead, but maybe not used how you're used to.

    In fact, firmware updates in 2.0+ have gotten much much simpler. As long as you're sticking to the full releases, you can upload a single zip file and the firmware will update everything as needed. That zip file contains the same bin files as before, along with the DWV zip file, but the firmware now extracts them itself and installs what's needed.

    In your case, you're just out of sync. Going forward it will be a lot simpler.



  • Thank you once more Paedrux, dragonn and dc42 🙂 I'll rollback to 2.03 later on today.



  • I did downgrade to v2.03, I installed Duet2CombinedFirmware.bin, DuetWiFiServer.bin and deleted /www, created a new one and decompressed DuetWebControl-1.22.6.zip in it. I confirmed with M115 that the firmware changed.
    However something is still not working 😞 I can get to DWC I can see the web interface but it won't connect, It says "MiniKosselWiFiTest ! off" after attempting to connect without success; I tried from 2 separate computers and different browsers however I am getting the same results. I can connect to the board via USB just fine but DWC does not want to cooperate. Any ideas? Thank you!



  • One note, I downgraded DWC to v1.21 and is working. It won't work with 1.22.6, is doing the same thing that was happening with 2.01RC1 but with 2.03.
    Please correct me if I am wrong but I do not think is the firmware that is conflicting with DWC. Hope you guys can give me some ideas to try. Thank you once more.



  • So just to confirm, you're running Firmware 2.03, DWC 1.22.6, wifi server 1.23?

    Check this guide for the steps of prepping the SD card with DWC files, and firmware files, and then using USB to update the firmware, and connect to the board via DWC.

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+2:+Configuration/38#s135

    It's geared towards the Maestro board, but applies mostly to the wifi as well.



  • @phaedrux

    Yes I did downgrade to ...

    FIrmware Version: 2.03 (2019-06-13b2)
    WiFi Server Version: 1.23

    I did try DWC 1.22.6 but it won't connect, I removed it and went back to 1.21 and does let me connect however it only works for a short period of time before it gives me the error ...

    "Request timeout The last HTTP request has timed out. Please make sure the connection between your device and the board is not interrupted. "

    I did this firmware changes via USB since DWC is not working, anyhow I will give a try to your suggestion tomorrow when I get home from work, is sleepy time now. I'll let you know how it goes. Thank you for your help 🙂



  • After a lot of hair pulling I think I got the board working on the bench, however I am unsure what fixed it since I been trying everything I could think off. I did check the guide that Phaedrux suggested I did notice that in /sys there where missing files ... config.json, sleep.g, stop.g, tfree0.g, tpost0.g and tpre0.g. I did generated a new config file downloaded and replaced the /sys. However I was still seeing disconnection to DWC, changed to 1.22.6 from 1.21 once more thereafter I was still experiencing drops every so often. I deleted all saved WiFi's with M588 S"*", re-added my AP with M587 S"networkname" P"password" and finally reset it again with M552 S0 and re-enabled it with M552 S1. cleared cache in my browser and tried again so far so good 🙂
    Thank you all for your help!


Log in to reply