Temp sensor fault when extruder motor engaged



  • Hello,

    I've been troubleshooting an issue in which the second extruder temp sensor on my machine reads completely fine, except when the opposite extruder motor engages (printing or just extruding filament). I have replaced all the wiring from the daughter-board to the thermistor, and even replaced the thermistor to ensure it's not shorting on the block or something like that. All insulation and wiring is clean and new.

    When the extruder engages, the temp instantly reads 2000C and the duet complains about short to other wiring after the sensor read fault.

    Any ideas what could be causing that?


  • administrators

    @darkstarone said in Temp sensor fault when extruder motor engaged:

    I have replaced all the wiring from the daughter-board to the thermistor

    Which daughter board is that?



  • I'm using a thermocouple board purchased from Filastruder:

    https://www.filastruder.com/products/temperature-sensor-boards-for-duet?variant=31621167044

    The thermocouple wiring for the first hotend runs down the same bundle and path as the secondary, and works 100% rock solid with no fluctuations. It is completely unaffected by movement of the primary or secondary extruder motor.



  • I did another test in which I swapped the problematic thermocouple to the other input on the daughterboard, and it does the same thing. I did the same test on the other known good cable (both inputs tested) and it seems to work fine. This must be some sort of short as indicated by the error message but I cannot locate it anywhere visible or with a multimeter. The wiring has solid continuity when tested with a multimeter. The cabling is a continuous flex Igus with 24 wires in it, twisted pair all the way down to DIN mounted breakout terminal. I tried replacing the cable to the problematic thermistor on the other side of the breakout terminal with new wiring, and moved completely away from the extruder wiring. Unless there's a break/cut internally in the flex cable somewhere that's making contact, I'm having trouble locating the cause.



  • Cross talk? One cable is running closer to the stepper cable? Switching of the stepper might cause large transients. I assume the filtering capacitors on the thermocouple board are way to small. I do not know how to put a shield on the thermocouple cable since it has two different wires and the end at thermocouple board makes the cold junction opposed to the hot junction at the heating block.

    I just viewed the picture of the product. They omitted the capacitors at all. Works fine on production test, but not in real world.


  • administrators

    Which version of the thermocouple daughter board do you have? The older one with MAX31855 chips didn't have the extra capacitors, but the wiki page about connecting thermocouples tells you how to add them. The newer one with MAX31856 chips has the capacitors.



  • @dc42 I'd have to double check, but they were purchased within probably the last 6-9 months from Filastruder so I'd hope they were the newer ones. I believe my config is setup for the newer ones, but not seeing any capacitors on it. I'll upload a picture of what I've got a bit later today.



  • @dc42 Here is what I have

    alt text
    alt text



  • This post is deleted!


  • Tried moving the wire to a spare set in the bundle and still experiencing the same issue. If the 2nd thermistor is disconnected, there is no short triggered.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.