Replacement Duex5 also not recognized



  • I'm building a Railcore II 300ZL kit from ProjectR3d and when I issued the M115 command using Repetier Host, the Duex5 was not listed. After checking the cables multiple times, disconnecting everything, etc., I requested an RMA. Received the replacement board today and installed it with the original ribbon cable as a new one was not sent. Still not recognized! ProjectR3d is sending a new cable but in the meantime, is there something special about the supplied ribbon cable or is it just standard 40 pin ribbon cable. I'm also not confident this will fix the issue so does anyone have any other ideas?
    thanks


  • administrators

    It's a standard 50-way ribbon cable.

    I guess there's a small chance that either the Duet isn't supplying 3.3v to the expansion connector or there is a break in the I2C signal. On the DueX there is a 10-pin header next to the expansion connector. When the DueX is connected to a Duet and power is applied to the Duet, you should be able to measure 3.3V between the 3.3V and ground pins, also 3.3V on the TWC and TWD pins. If you try to measure this, take great care not to short the +3.3V pin to the adjacent +5V pin.



  • Thanks for the quick response. I made a couple of test leads and measured a good 3.3V between the 3.3V, TWD, and gnd. However when I measured TWC, twice, it registered only 136mV. The Duex5 has been swapped and although much longer than the provided ribbon cable, I had an old 50 pin SCSI cable which I tried with the same negative result. So I assume that would point to a problem with the Duet-wifi card.
    Thanks


Log in to reply