Duet Wifi V1 and Duex 5 Not Working

  • Hi Guys,

    I recently went to turn on my printer and the 2 steppers I have connected to P5 and P6 (dual Z) are not responding and wifi is not working either. No other steppers are currently connected. I ran M115 and it looks like it's not reading my Duex5 for some reason (plus whatever else the report entails) and the 2 heater LEDs closest to VIN are lit when the board is powered on. Also seeming to indicate there is an issue with the expansion board are the results from M122 P101 which came back "Expander status 0000". My PanelDue is still working, so that's good 🙂

    I honestly think the only thing I did since the last time it was working was to remove the SD card and remap my X and Y drives for my new setup and after restarting it, I am where I am now. I tried reverting back to the previous config but to no avail so I'm not sure the problem is there, but I'd be lying if I said I had any idea what is happening right now lol The report is below, apologies for the image, my printer is in a different room than my regular computer.


    Possibly related but maybe not.... but I'm in the process of re-doing my setup so I've disconnected everything except for the 2 Z steppers and 1 limit switch, leaving the wires themselves still connected to the board though since there is a separate connection point nearer to the motors and extruder so that is where they were disconnected.

    Anyhow, any help would be really appreciated and hopefully I didn't bin it 😕

    .......Config below......

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ; generated by RepRapFirmware Configuration Tool on Fri May 05 2017 18:12:44 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X1500 Y500 Z1500 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 E1 Z0 S1 ; Define active low and unused microswitches
    M558 P5 X0 Y0 Z1 H5 F120 T6000 ; Set Z Probe to type Switch or Digital output where Z probe connector is used. Used for z only.;
    G31 P50 X-30 Y-2 Z1.8 ; Set Z probe trigger value, offset and trigger height
    M557 X30:1450 Y20:500 S45 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards x dir
    M569 P1 S1 ; Drive 1 goes backwards Y dir
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes forwards x dir
    M569 P4 S0 ; Drive 4 goes backwards
    M569 P5 S1 ; Drive 5 goes backwards Z dir
    M569 P6 S0 ; Drive 6 goes forwards Z dir
    M584 X0:3 Y1 Z5:6 E2:4 ; Apply custom drive mapping
    M671 X-140:1670 Y370:370 S1.5 ; Tilt compensation/gantry leveling
    M350 X64 Y64 Z64 E32:32 I1 ; Configure microstepping with interpolation
    M92 X213.22 Y213.22 Z1008.56 E1335.98:1335.98 ; Set steps per mm
    M566 X600 Y300 Z20 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y3000 Z180 E1200:1200 ; Set maximum speeds (mm/min)
    M201 X900 Y450 Z20 E250:250 ; Set accelerations (mm/s^2)
    M906 X2200 Y2200 Z2200 E1680:1680 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S280 ; Set maximum heater temperature to 260C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4725 C7.06e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4725 C7.06e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M307 H7 A-1 C-1 D-1 ; Disable Heater to use for BLTouch Servo

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R160 S200 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X55 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Network
    M550 PMyDuet ; Set machine name
    M552 P192.168.1.5 S1 ; Enable network and acquire dynamic address via DHCP

    ; Fans
    M106 P0 S1 I0 F500 H1:2 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P0.1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

  • administrators

    The M122 report says the VIN voltage is 36V. That could either mean that the supply voltage really is 36V, or that the 3.3V rail is low (the 3.3v rail is used as the voltage reference for measuring VIN). If the 3.3V rail is low, then that's probably because the SD card or WiFi module has blown and is drawing excessive current, and getting hot. So check what is getting hot.

    Also the MCU temperature reading is silly. I'm not sure whether a low 3.3V rail would cause that.

  • @dc42

    Hi David,

    Thanks for getting back to me, when I get home I will check the voltage at the power supply and VIN to see what they are at, which should be 24v. I'll use my rinky-dink temp gun to see if those temps are even close to what they are reading as also. What else should I check?

    Is the SD card needed to initialize the expansion board? I'm guessing that it is needed to read the IP from the config, so if the SD card is not working, that might explain that, just not sure about the expansion.

    Hopefully I haven't bricked my board, I was just about ready to start testing my new nimble setup and then this happened lol

  • @dc42

    I couldn't find my temp gun, but I measured the voltage at VIN and it was indeed 24v. At this stage, I'm not sure how to test if the SD card and/or WIFI is blown so any tips would be appreciated.

  • administrators

    I think you will find that either the SD card or one or more components on the Duet are getting hot, indicating failure of that item. Or possibly a component on the DueX5, if that is still connected.

  • @dc42

    So there are no points I can probe with my MM to get a reading that would be more conclusive? Or anything that would be more conclusive?

    If not and temp is the only outward indication of these failures, would any heat coming from the SC card indicate failure or is there a range that I need to verify that it has exceeded?

    The issue started with the Duex5 connected, but I later disconnected it, but it did not seem to change anything for the better, or at all that I could tell. The only thing I noticed is that with the Duex5 connected, I see a "Connected" message in the Console of the PanelDue, but when I disconnected the Duex5 it didn't say anything. I'm just not sure if that is to be expected or not.

    Do the 2 heater LEDs on the Duex5 being illuminated when not being used indicate anything? I don't recall them ever being on before.

    Normally I'd say, oh well and suck it up and get the latest board but I don't want to make the same mistake again if it is something I did wrong. Plus, I'm planning my first trip to the UK next month so I will have no money for a while, so if my board is well and truly borked, it might be a while until I can replace it. Really hoping there is a fix lol

  • @dc42

    I checked the temp on the SD Card and at startup it was 23c and only got as high as 29c after about 10 minutes of idling. I got this with my IR temp gun and a thermocouple. I also did a sweep of the board with the IR gun and got a hot spot around 52c to the right of the Atmel and below the PWM fan connectors (with board oriented VIN on the right). With it being an IR gun, I can't really narrow it down much more. I also did a sweep of the Duex5 and nothing really spiked but I can get more specific notes if that would help.

  • @dc42

    Hi David, really sorry to keep bugging you, but I'm not quite sure how to proceed.

    Apart from what I did in my last message, I'm not sure what else to test to figure out what is wrong and more to the point, if it is salvageable. If it is not, then I would like to determine (if possible) what hardware needs to be replaced and go from there, but I don't know if I need a new Duet, Duex5 or both?

    Also, if I only need to replace one of the two, would my 0.7 Duex5 work with a new Duet 2? Or would my Duet wifi 1.02 work with a new Duex5?

Log in to reply