Problem with extruder motor



  • Printer was working fine after upgrading to Duet Wifi. Then I went to change the extruder to a Titan geared extruder. Knowing I needed to change the steps because off the gear reduction I removed just the extruder and motor ( Using the same motor that was working fine before) and placed it on my bench to calibrate the extrusion steps. Turned power on, sent a T0 then M302 P1 then G1 E100 F600, the extruder worked fine. Then I sent another G1 E100 F600 and nothing happened. I tried several more times but the extruder didn't turn. No error messages in the console. Tried sending all the commands again and nothing. I could here the motor holding so I sent a M18 and the motor turned off, then tried again and nothing. Then I rebooted the board and still nothing. Then I powered the board off and back on, then sent the same series of commands and it worked, tried to send a second G1 command and nothing. If I power the board off and back on it will work the first time every time I recycle power but after that it won't respond until I recycle power. All other motors work fine, this problem seems to be isolated to the extruder motor. Any Ideas what is going on? Thanks


  • administrators

    My guess is that you have a temperature set for tool 0 and you are getting a heating fault within a few seconds of sending the T0 command. Have you checked the DWC Console page for messages?



  • The Console shows no error messages. The DWC shows the heater is off

    Here's the tool definition section:

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C



  • When I send the extrude command after re-powering the heater goes "active" but no faults


  • administrators

    I've just thought of another possibility, which is that you are in absolute extrusion mode. Try sending M83.



  • Thanks, that was the problem. I'm frustrated that I missed that. Argh I should have known that.
    Thanks again dc42


Log in to reply