Probe problem.



  • Hi, I need a bit of help to get the probe to work..

    I have the 1.2 probe and I cant get it to detect… probe value reads 1000, 96x sometimes. ( even in a dark room.)

    Its connected as follows and I have verified connectivity
    Probe->DuetWifi
    Out - In
    Gnd-gnd
    Vcc-3.3v
    -mod not connected.
    When USB powered on it flashes red one time.

    Here is how its defined..
    ; Endstops
    M574 X1 Y1 Z1 S0 ; Define active low and unused microswitches
    M558 P1 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to modulated, the axes for which it is used and the probe + travel speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:355 Y15:235 S20 ; Define mesh grid


  • administrators

    If it's flashing only once instead of four times, that sounds to me like a power problem. If the usb power is coming from a port on a laptop, it may not provide enough power for the Duet.



  • Hi David,

    The power is ok, I tesed difference power options and it makes no differance. Plus in all situations it manage to drive the paneldue at the same time.

    Are my config settings ok, I have not changed anything else…

    Anything else I can try?



  • I have made a new very short test cable just to rule that out and sorry to say that the result is just the same. A short single red and nothing more.



  • A short video to show connections and behaviour.
    https://www.youtube.com/watch?v=zcoGgfYQIQc


  • administrators

    If you are certain that power is reaching the sensor solidly, then you should ask your supplier for a replacement sensor. if you have a multimeter, please check for power on the sensor first. Put the positive multimeter lead on either side of L1, and the negative on the ground test point just above D2. You should get 3.3V.



  • I had the exact same symptoms the other day. It turns out I was using the wiring diagram from the production Duet with my beta (white) board. The probe connection is inverted between the two.

    Could that be a factor here?

    David



  • I have no power on the probe volt socket on my duet.
    Do I need to enable it or is it always on?


  • administrators

    It's always on. Check that you have the right connections - see adavidm's post. The pins are also labelled on the underside of the Duet.



  • Somehow I manage to read the pinout mirrored but its corrected and it works as it should from a power on perspective.

    Are the only FW changes needed those that I made below? Should Z1 still be in M574?
    Have tested to put my hand under the probe when homing Z but it does not stop but the LED turns red… Doing a safe test here..
    M574 X1 Y1 Z1 S0
    M558 P1 X0 Y0 Z1 H5 F120 T6000
    G31 P500 X0 Y0 Z0.5
    ;M557 X15:355 Y15:235 S20



  • Now I have set it exactly as in https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer

    M558 P1 X0 Y0 Z1 H3 F200 T5000 R0 ; smart IR Z probe, used for homing Z axis only, dive height 3mm, probe speed 200mm/min, travel speed 5000mm/min, no recovery time
    G31 P500 X11.0 Y0.5 Z1.65 ; set threshold and offsets

    it still does not stop..



  • M558 should be P5 not P1



  • The P value on Z probe reacts and output 538 when I hold my hand so I assume its the configuration I need to fix…



  • P5 but on the Wiki it is clearly stated that it should be P1 for a IR probe.



  • Yes mine is P1 as well and works



  • My fault I was thinking of a different kind of setup!



  • Could you please post your config.g Dougal?



  • Are you on a delta



  • But here it is

    ; Configuration file for Mini Kossel kit from Think3DPrint3D

    ; Communication and general
    M111 S0 ; Debug off
    M550 PMidiKossel ; Machine name and Netbios name (can be anything you like)
    M551 Preprap ; Machine password (used for FTP)
    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xEF ; MAC Address
    ;*** Wifi Networking
    M552 S1 ; Enable WiFi

    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue

    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ; Axis and motor configuration
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M574 X2 Y2 Z2 S1 ; set endstop configuration (all endstops at high end, active high)
    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration
    M665 R261.30 L520 B175 H336.93 X0.14 Y0.09 Z0 ; set delta radius, diagonal rod length, printable radius and homed height
    M666 X-1.51 Y0.61 Z1.15 ; put your endstop adjustments here, or let auto calibration find them
    M350 X16 Y16 E16 I1 ; Set 16x microstepping with interpolation
    M92 X80 Y80 Z80 ; Set axis steps/mm
    M906 X1000 Y1000 Z1000 E400 I60 ; Set motor currents (mA) and increase idle current to 60%
    M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2)
    M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min)
    M566 X1200 Y1200 Z1200 E1200 ; Maximum instant speed changes mm/minute

    ; Thermistors
    M305 P0 T100000 B4287 R4700 ;H30 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 X200 ;H30 L0 T100000 B4388 R4700 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    ;M305 P2 T100000 B3974 R4700 H30 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    M570 S180 ; Hot end may be a little slow to heat up so allow it 180 seconds
    M143 S280
    ;M307 H0 A182.6 C1031.3 D14.8 S0.8 B0
    M307 H1 A491.4 C177.6 D4.5 B0

    ; Tool definitions
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;*** If you have a single-nozzle build, comment the next 2 lines
    ;M563 P1 D1 H2 ; Define tool 1
    ;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures
    M92 E397:663 ; Set extruder steps per mm

    ; Z probe and compensation definition
    ;*** If you have a switch instead of an IR probe, change P1 to P4 in the following M558 command
    M558 P1 X0 Y0 Z0 H5 ; Z probe is a switch and is not used for homing any axes
    G31 X0 Y0 Z2.55 P500 ; Set the zprobe height and threshold (put your own values here)

    ;*** If you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0 ; Axis compensation here
    M557 R150 S20
    M208 S1 Z-0.2 ; set minimum Z
    ;
    M572 D0 S0.15
    ;
    T0 ; select first hot end



  • Ok, I have a cartheasian.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.