Cannot initialise SD card



  • Hi,
    my Duet Wifi, after working flawlessly for months, has developed a problem reading the SD card. This is what it says:

    Cannot initialise SD card 0: Card is unusable, try another oneRepRapFirmware for Duet WiFi Version 1.15b dated 2016-08-25
    Executing default.g (no configuration file found)...Error, not found
    Network disabled.
    RepRapFirmware for Duet WiFi is up and running.
    Printer is now online.
    
    

    So far I tried:

    • re-format supplied SD card. (format in MS-DOS FAT32, then copy the folders 'sys', 'macros', and 'gcode' back onto the card) -> no luck

    • tried a different card I had lying around. -> no luck

    I'm not sure, what I should try next.

    • Does the sd card has to be formatted with a more obscure file system?
    • Could it be a problem with the firmware on the Duet?
    • any other ideas I haven't thought of, yet?

    Thanks, Wilko


  • administrators

    Formatting the card as FAT32 is correct. When you run M122, does the report indicate that the card is detected?



  • yes, but the interface speed seems odd (see output below).
    If I remove the card and run M122 again, it says 'SD card 0 not detected, interface speed: 0.2MBytes/sec'.
    If I start the Duet without card and run M122, I get 'SD card 0 not detected, interface speed: 30.0MBytes/sec'.

    Diagnostics
    Used output buffers: 1 of 32 (2 max)
    Platform Diagnostics:
    Memory usage:
    Program static ram used: 13132
    Dynamic ram used: 81780
    Recycled dynamic ram: 3392
    Current stack ram used: 2752
    Maximum stack ram used: 3584
    Never used ram: 29184
    Last reset 00:00:14 ago, cause: power up
    Error status: 0
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000 0.000
    Free file entries: 10
    SD card 0 detected, interface speed: 0.2MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 24.5, current 26.6, max 27.6
    Supply voltage: min 0.4, current 0.6, max 0.9, under voltage events: 0, over voltage events: 0
    Slowest main loop (seconds): 0.000512; fastest: 0.000042
    Move Diagnostics:
    MaxReps: 0, StepErrors: 0\. Underruns: 0
    Heat Diagnostics:
    Bed heater = 0, chamber heater = -1
    GCodes Diagnostics:
    Move available? no
    Stack pointer: 0 of 5
    macro is idle
    http is idle
    telnet is idle
    serial is ready with "M122"
    aux is idle
    file is idle
    Network Diagnostics:
    WiFiServer is disabled
    SPI underruns 0, overruns 0
    Webserver Diagnostics:
    HTTP sessions: 0 of 8
    ok
    
    

 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.