Not homing correctly



  • Hello recently i updated the firmware on my duet maestro 1.0 to 2.03RC5 and when i home the printer sometimes it works and sometimes it doesn't. When it doesnt work it shows the error G0/G1: target position not reachable from current position and the only way to get it to home agin to to do and emergency stop and home it again. Also its a delta. Any idea what this problem is?



  • Please do share your config.g and homeall.g files



  • ; Configuration file for Duet Maestro (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Sun Sep 15 2019 09:51:59 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"3dp" ; set printer name
    M665 R126 L267 B80 H598 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them

    ; Network
    M552 P0.0.0.0 S1 ; enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E92.60 ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00 ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; set minimum Z

    ; Endstops
    M574 X1 Y1 Z1 S1 ; set active high endstops

    ; Z-Probe
    M558 P4 H5 F120 T6000 ; set Z probe type to switch and the dive height + speeds
    G31 P1000 X0 Y0 Z16 ; set Z probe trigger value, offset and trigger height
    M557 R80 S10 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings
    M564 H0

    Mine doesnt have a homeall.g file do you want the homedelta.g ???



  • @foxmike111 said in Not homing correctly:

    do you want the homedelta.g ???

    oh, yes please, my bad.

    Do you have any deployprobe and retractprobe files as well?



  • @foxmike111 said in Not homing correctly:

    1.0 to 2.03RC5

    for delta printer you should go with 2.04rc at the moment.

    @foxmike111 said in Not homing correctly:

    M665 R126 L267 B80 H598 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them

    these are not tuned parameters. please read
    https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer
    and save the correct ones

    @foxmike111 said in Not homing correctly:

    M305 P0 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 1

    B4138 is the default and almost certainly wrong for your thermistors. you need to enter the correct value for your thermistor.

    @foxmike111 said in Not homing correctly:

    G31 P1000 X0 Y0 Z16 ; set Z probe trigger value, offset and trigger height

    you will need to find the correct offset. Z16 seems to convenient.



  • For my thermistors i use these
    https://www.amazon.com/Anycubic-Thermistor-Wiring-Printer-Heatbed/dp/B01B41K7OM/ref=sr_1_3?keywords=anycubic+NTC+3950+100k&qid=1568564308&sr=8-3
    For the B4138 should it be B3950?
    Ill also switch back to 2.04rc and tune the parameters



  • @bearer
    ; homedelta.g
    ; called to home all towers on a delta printer
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Sun Sep 15 2019 09:52:00 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning

    G1 S1 X603 Y603 Z603 F1800 ; move all towers to the high end stopping at the endstops (first pass)
    G1 X-5 Y-5 Z-5 F1800 S2 ; go down a few mm
    G1 S1 X10 Y10 Z10 F360 ; move all towers up once more (second pass)
    G1 Z-5 F6000 ; move down a few mm so that the nozzle can be centred
    G90 ; absolute positioning
    G1 X0 Y0 F6000 ; move X+Y to the centre

    I dont have those files.



  • @foxmike111 said in Not homing correctly:

    For the B4138 should it be B3950?

    if that is the thermistor that you are using then yes.
    but only if you have changed the thermistor to this specific one. anycubic uses a lot of different thermistors in their printers.



  • @Veti
    Thanks ill change it now.


Log in to reply