Two motors for one axis except the Z(2) connectors



  • Hello, I am a newby in using Duet2, so excuse me if the question is to easy. I didn't found infos about that.
    On the Duet2 are more than 3 motor connectors. Is it possible to connect two motors for one axis according to the Z axis? I have to use two motors for the X and two for the Y axis. The Y axis motors I connected to the two Z connectors, so I need one more possibility for two motors of the X axis. In the configuration tool I found only the Z(2), is it not possible to config one of the connectors behind X to work with X together?
    Best regards,
    Gerd




  • administrators

    Three options:

    1. If you are not already using 5 drivers, connect the two axis motors to different outputs, then use M584 to tell the firmware you did that. This is the best solution for axes that need to move quickly.

    2. Connect the two motors in series to a single output (which is how the two Z motor connectors are wired). This works well for low inductance/medium-to-high current motors, especially if you are using 24V power.

    3. Connect the two motors in parallel to a singe output. This works OK for low current/high inductance motors.



  • Hello,

    @DocTrucker : ok, I will read this doku asap, thank you.

    @dc42 : Option 1 I found and tried before I post this question. The problem was that the secound motor dosen't move and I had no idea why and if this is intended for that. I'll try again, now knowing that it has to work 🙂

    I think the best way is to use two different motor drivers for this instead of put them together in series or parallel, espacially the Duet2 have enough motor drivers for that.

    Thank you very much!

    Addition questions: In the config tool I have to define the current on each axis. How is the way to get a correct value for that? And how is the way to define the moving speeds and other values?

    Best regards,
    Gerd



  • Ok, M584 works! Great! I had to put it in the config.g instead of run it in the console. That was the fault.
    Thank you!
    Bye until I have the next problem 🙂
    Best regards
    Gerd


Log in to reply