Trouble understanding how to set up Z-probe offset



  • Hi,

    As a delta owner coming from Smoothieware I'm having some trouble wrapping my head around setting up my Z-probe and calibration.
    So I was hoping for some help from the experts here.

    My machine has magnetic arms which I use to swap between my effector with Z-probe and another effector with my hotend.
    (to keep the hotend light and compact)

    I can succesfully run auto calibration and mesh bed compensation however don't understand how/where to put my probe/hotend Z-offset.

    My Z-probe is configured as:
    M558 P5 X0 Y0 Z0 H40 F300 T2000 R0
    G31 X0 Y0 Z0 P500

    When I manually move until the Z-probe is triggered Z=20.70
    When I swap to my effector with hotend and manually place it to touch the bed my Z is 18.73

    In smoothieware I normally place the effector to touch the bed then do:
    M306 Z0
    M500

    Which stores the offset in an override file as:
    M206 Zn.n ; (n.n is measured offset)

    I'm trying to wrap my head around how/what to do this on my Duet Wifi (which I like much more!)
    It seems G92 Z0 defines the current Z as Z=0, however this does not seem persistent after homing or a power cycle.
    Or should I manually calculate a rough offset and place it somewhere in th config/bed file (where?), and then rely on baby stepping for fine tuning?

    Probably a simple thing but I'm just a bit confused for the best solution, any help? 🙂


  • administrators

    It is indeed the G92 Z parameter that defines the Z probe offset. However, when you run M500, the current Z probe offset parameters are amongst those written to config-override.g. So your config-override.g file may be overriding the value that you put in config.g. So you can send a G31 command with the parameters you want, then send M500 to save them.

    config-override.g is only used if you have the command M501 (or M98 Pconfig-override.g) in your config.g file.

    HTH David



  • Ok looks like I've got it to work by adjusting the G31 Z in config.g in a few iterations.
    Never got that G92 Z0 to work always seemed to be reset after doing a home.
    But it may be me being stupid as a newbie 🙂

    Really liking the board, firmware and web interface so far, you've done an incredible job!


  • administrators

    I'm glad you like it!

    Sending G92 Z0 and homing Z are two different ways of defining where Z=0 is. So homing Z will cancel the effect of previously running G92 Z0.



  • I am sorry that I also do not understand this. I, too, am coming from smoothie. In the past, I would do a g32 with a microswitch. It would check for bed level at some unknown height above the bed. Then I would remove the microswitch, lower the nozzle til just touching the paper, G92 Z0 and M500. boom.

    With this, I have been trying for over an hour. I did the autocalibration with the microswitch on. And then I removed the microswitch. Z0 results in the nozzle sitting 18.64mm above the bed.

    I tried to follow this:
    https://www.duet3d.com/wiki/Calibrating_a_delta_printer

    I use M208 S1 Z-20 to allow the nozzle to move down.
    I use G Z-18.64 to lower nozzle to piece of paper (that works)

    then I have tried changing this in the config:
    G31 P600 X11 Y0 Z0 ; Set Z probe trigger value, offset and trigger height
    to
    G31 P600 X11 Y0 Z18.64 ; Set Z probe trigger value, offset and trigger height

    but still when Z0 the nozzle is at 18.64mm above bed.

    I've deleted the last few lines from the config-override and then lowered nozzle to bed, used g92 Z0 then M500, reopened config-override:
    G31 T1 P500 X0.0 Y0.0 Z0.70
    G31 T3 P500 X0.0 Y0.0 Z0.70
    G31 T4 P600 X11.0 Y0.0 Z18.64

    How do I convince my machine that it needs to be 18.64mm lower?

    I decided to go into config-override and I changed this line:
    M665 L304.170 R151.502 H241.959 B125.0 X0.025 Y0.027 Z0.000 ;
    to
    M665 L304.170 R151.502 H260.599 B125.0 X0.025 Y0.027 Z0.000 ;new-H260.599 old-H241.959

    basically, I told the machine that it was 18.64mm taller than it calibrated at. That seems to work. but what is the correct way?


  • administrators

    It sounds to me that you adjusted the G31 Z parameter to 18.64 after you had run auto calibration, instead of before. The firmware needs to know the Z probe trigger height during probing.

    With a removable probe, your approach of adjusting the homes height afterwards is equally valid.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.